aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tinylogin
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-13 08:46:41 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-13 08:46:41 +0000
commit1841db4796e29019f252c5a34e1b989d993437bc (patch)
tree7a6da3efca40bd30b71b2672df0c29c5d2768fd7 /packages/tinylogin
parent1021872a44c22e64466ceab4cbebcca19baec63c (diff)
downloadopenembedded-1841db4796e29019f252c5a34e1b989d993437bc.tar.gz
tinylogin: make it build against uclibc 0.9.29
* patch based on the buildroot patch for module-init-tools
Diffstat (limited to 'packages/tinylogin')
-rw-r--r--packages/tinylogin/tinylogin-1.4/remove-index.patch11
-rw-r--r--packages/tinylogin/tinylogin_1.4.bb5
2 files changed, 14 insertions, 2 deletions
diff --git a/packages/tinylogin/tinylogin-1.4/remove-index.patch b/packages/tinylogin/tinylogin-1.4/remove-index.patch
new file mode 100644
index 0000000000..fc35002bad
--- /dev/null
+++ b/packages/tinylogin/tinylogin-1.4/remove-index.patch
@@ -0,0 +1,11 @@
+--- /tmp/deluser.c 2007-05-13 10:38:19.000000000 +0200
++++ tinylogin-1.4/deluser.c 2007-05-13 10:38:50.185251000 +0200
+@@ -60,7 +60,7 @@
+ }
+ start++;
+
+- stop = index(start, '\n'); /* index is a BSD-ism */
++ stop = strchr(start, '\n'); /* index is a BSD-ism, strchr hopefully isn't */
+ b.start = start - buffer;
+ b.stop = stop - buffer;
+ return b;
diff --git a/packages/tinylogin/tinylogin_1.4.bb b/packages/tinylogin/tinylogin_1.4.bb
index 33f1c32aed..ad254bff6a 100644
--- a/packages/tinylogin/tinylogin_1.4.bb
+++ b/packages/tinylogin/tinylogin_1.4.bb
@@ -5,12 +5,13 @@ changing passwords, and otherwise maintaining users \
and groups on an embedded system."
HOMEPAGE = "http://tinylogin.busybox.net/"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
file://cvs-20040608.patch;patch=1;pnum=1 \
file://add-system.patch;patch=1;pnum=1 \
- file://adduser-empty_pwd.patch;patch=1"
+ file://adduser-empty_pwd.patch;patch=1 \
+ file://remove-index.patch;patch=1"
EXTRA_OEMAKE = ""