aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tinylogin
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/tinylogin
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/tinylogin')
-rw-r--r--packages/tinylogin/tinylogin_1.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/tinylogin/tinylogin_1.4.bb b/packages/tinylogin/tinylogin_1.4.bb
index e69de29bb2..d028c9a8e6 100644
--- a/packages/tinylogin/tinylogin_1.4.bb
+++ b/packages/tinylogin/tinylogin_1.4.bb
@@ -0,0 +1,28 @@
+SECTION = "base"
+DESCRIPTION = "TinyLogin is a suite of tiny UNIX \
+utilities for handling logins, user authentication, \
+changing passwords, and otherwise maintaining users \
+and groups on an embedded system."
+HOMEPAGE = "http://tinylogin.busybox.net/"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
+ file://cvs-20040608.patch;patch=1;pnum=1 \
+ file://add-system.patch;patch=1;pnum=1 \
+ file://adduser-empty_pwd.patch;patch=1"
+
+EXTRA_OEMAKE = ""
+
+do_compile () {
+ oe_runmake 'CC=${CC}' 'CROSS=${HOST_PREFIX}'
+}
+
+do_install () {
+ install -d ${D}/${base_bindir}
+ install -m 4755 tinylogin ${D}/${base_bindir}/tinylogin
+ for i in `cat tinylogin.links`; do
+ mkdir -p ${D}/`dirname $i`
+ ln -sf /bin/tinylogin ${D}/$i
+ done
+}