aboutsummaryrefslogtreecommitdiffstats
path: root/packages/totem
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/totem
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/totem')
-rw-r--r--packages/totem/.mtn2git_empty0
-rw-r--r--packages/totem/totem-0.99.15/.mtn2git_empty0
-rw-r--r--packages/totem/totem-0.99.15/include.patch11
-rw-r--r--packages/totem/totem-0.99.15/omf.patch13
-rw-r--r--packages/totem/totem_0.99.15.bb30
5 files changed, 54 insertions, 0 deletions
diff --git a/packages/totem/.mtn2git_empty b/packages/totem/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/totem/.mtn2git_empty
diff --git a/packages/totem/totem-0.99.15/.mtn2git_empty b/packages/totem/totem-0.99.15/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/totem/totem-0.99.15/.mtn2git_empty
diff --git a/packages/totem/totem-0.99.15/include.patch b/packages/totem/totem-0.99.15/include.patch
index e69de29bb2..6e99c4e21e 100644
--- a/packages/totem/totem-0.99.15/include.patch
+++ b/packages/totem/totem-0.99.15/include.patch
@@ -0,0 +1,11 @@
+--- totem-0.99.15/src/video-utils.c 2004-07-03 16:54:31.000000000 -0700
++++ totem-0.99.15.new/src/video-utils.c 2004-08-04 11:03:30.822669856 -0700
+@@ -4,7 +4,7 @@
+ #include "video-utils.h"
+
+ #include <glib/gi18n.h>
+-#include <libintl.h>
++/* #include <libintl.h> */
+
+ #include <gdk/gdk.h>
+ #include <gdk/gdkx.h>
diff --git a/packages/totem/totem-0.99.15/omf.patch b/packages/totem/totem-0.99.15/omf.patch
index e69de29bb2..a889db10ba 100644
--- a/packages/totem/totem-0.99.15/omf.patch
+++ b/packages/totem/totem-0.99.15/omf.patch
@@ -0,0 +1,13 @@
+--- totem-0.99.12/omf.make 2003-11-08 18:04:41.000000000 -0700
++++ totem-0.99.12.new/omf.make 2004-06-30 09:39:58.765495480 -0700
+@@ -41,7 +41,9 @@
+ install-data-hook-omf:
+ $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ for file in $(omffile); do \
+- $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ if [ -f $$file.out ]; then \
++ $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ fi; \
+ done
+ -scrollkeeper-update -o $(DESTDIR)$(omf_dest_dir)
+
diff --git a/packages/totem/totem_0.99.15.bb b/packages/totem/totem_0.99.15.bb
index e69de29bb2..aaf956917f 100644
--- a/packages/totem/totem_0.99.15.bb
+++ b/packages/totem/totem_0.99.15.bb
@@ -0,0 +1,30 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.hadess.net/totem.php3"
+LICENSE="GPL"
+
+SRC_URI="http://www.hadess.net/files/software/totem/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine libgnomeui"
+RDEPENDS += " libgnomeui"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}