aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tslib
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-10 12:21:49 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-10 12:21:49 +0000
commit3c230a820d316dc759c384b58d466c3528267661 (patch)
treee8e75bc708aae9417671e9ec1068cdbd9dd35d8a /packages/tslib
parent7814da98a7630811db9fc24db9ae3c81588ca113 (diff)
downloadopenembedded-3c230a820d316dc759c384b58d466c3528267661.tar.gz
hx4700, hx2000: start adding support for hx4700 and hx200 ipaqs to solve overloading of the ipaq-pxa270 machine
* the ipaq-pxa270 machine will go away
Diffstat (limited to 'packages/tslib')
-rw-r--r--packages/tslib/tslib/hx2000/.mtn2git_empty0
-rw-r--r--packages/tslib/tslib/hx2000/tslib.sh6
-rw-r--r--packages/tslib/tslib/hx4700/.mtn2git_empty0
-rw-r--r--packages/tslib/tslib/hx4700/tslib.sh6
-rw-r--r--packages/tslib/tslib_1.0.bb3
5 files changed, 14 insertions, 1 deletions
diff --git a/packages/tslib/tslib/hx2000/.mtn2git_empty b/packages/tslib/tslib/hx2000/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tslib/tslib/hx2000/.mtn2git_empty
diff --git a/packages/tslib/tslib/hx2000/tslib.sh b/packages/tslib/tslib/hx2000/tslib.sh
new file mode 100644
index 0000000000..3a6ba78c50
--- /dev/null
+++ b/packages/tslib/tslib/hx2000/tslib.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+TSLIB_TSDEVICE=/dev/input/touchscreen0
+TSLIB_CONFFILE=/usr/share/tslib/ts-2.6.conf
+
+export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/packages/tslib/tslib/hx4700/.mtn2git_empty b/packages/tslib/tslib/hx4700/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tslib/tslib/hx4700/.mtn2git_empty
diff --git a/packages/tslib/tslib/hx4700/tslib.sh b/packages/tslib/tslib/hx4700/tslib.sh
new file mode 100644
index 0000000000..3a6ba78c50
--- /dev/null
+++ b/packages/tslib/tslib/hx4700/tslib.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+TSLIB_TSDEVICE=/dev/input/touchscreen0
+TSLIB_CONFFILE=/usr/share/tslib/ts-2.6.conf
+
+export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/packages/tslib/tslib_1.0.bb b/packages/tslib/tslib_1.0.bb
index ddd6c5ad6d..2472ece610 100644
--- a/packages/tslib/tslib_1.0.bb
+++ b/packages/tslib/tslib_1.0.bb
@@ -34,7 +34,7 @@ do_install_append() {
install -d ${D}${sysconfdir}/profile.d/
install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
case ${MACHINE} in
- a780 | e680 | h3600 | h3900 | h5xxx | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel | h4000)
+ a780 | e680 | h3600 | h3900 | h5xxx | h1940 | h6300 | h2200 | ipaq-pxa270 | hx4700 | hx2000 |blueangel | h4000)
install -d ${D}${datadir}/tslib
for f in ts-2.6.conf ts.conf-h3600-2.4; do
install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
@@ -79,6 +79,7 @@ RDEPENDS_tslib-conf_h6300 = "detect-stylus"
RDEPENDS_tslib-conf_blueangel = "detect-stylus"
RDEPENDS_tslib-conf_htcuniversal = "detect-stylus"
RDEPENDS_tslib-conf_h4000 = "detect-stylus"
+RPROVIDES_tslib-conf = "libts-0.0-conf"
PACKAGE_ARCH_tslib-conf = "${MACHINE_ARCH}"
PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"