aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ttf-fonts
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/ttf-fonts
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/ttf-fonts')
-rw-r--r--packages/ttf-fonts/.mtn2git_empty0
-rw-r--r--packages/ttf-fonts/ttf-dejavu_1.11.bb18
-rw-r--r--packages/ttf-fonts/ttf.inc19
3 files changed, 37 insertions, 0 deletions
diff --git a/packages/ttf-fonts/.mtn2git_empty b/packages/ttf-fonts/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ttf-fonts/.mtn2git_empty
diff --git a/packages/ttf-fonts/ttf-dejavu_1.11.bb b/packages/ttf-fonts/ttf-dejavu_1.11.bb
index e69de29bb2..64d0ac3e60 100644
--- a/packages/ttf-fonts/ttf-dejavu_1.11.bb
+++ b/packages/ttf-fonts/ttf-dejavu_1.11.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "DejaVu font - TTF Edition"
+LICENSE = "Bitstream Vera"
+HOMEPAGE = "http://dejavu.sourceforge.net/wiki/index.php/Main_Page"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/dejavu/dejavu-ttf-${PV}.tar.gz"
+
+include ttf.inc
+
+S = "${WORKDIR}/dejavu-ttf-${PV}"
+
+PACKAGES = "ttf-dejavu-sans ttf-dejavu-sans-mono ttf-dejavu-sans-condensed \
+ ttf-dejavu-serif ttf-dejavu-serif-condensed"
+
+FILES_ttf-dejavu-sans = "${datadir}/fonts/truetype/DejaVuSans.ttf ${datadir}/fonts/truetype/DejaVuSans-*.ttf"
+FILES_ttf-dejavu-sans-mono = "${datadir}/fonts/truetype/DejaVuSansMono.ttf ${datadir}/fonts/truetype/DejaVuSansMono-*.ttf"
+FILES_ttf-dejavu-sans-condensed = "${datadir}/fonts/truetype/DejaVuSansCondensed.ttf ${datadir}/fonts/truetype/DejaVuSansCondensed-*.ttf"
+FILES_ttf-dejavu-serif = "${datadir}/fonts/truetype/DejaVuSerif.ttf ${datadir}/fonts/truetype/DejaVuSerif-*.ttf"
+FILES_ttf-dejavu-serif-condensed = "${datadir}/fonts/truetype/DejaVuSerifCondensed.ttf ${datadir}/fonts/truetype/DejaVuSerifCondensed-*.ttf"
diff --git a/packages/ttf-fonts/ttf.inc b/packages/ttf-fonts/ttf.inc
index e69de29bb2..4cf5262280 100644
--- a/packages/ttf-fonts/ttf.inc
+++ b/packages/ttf-fonts/ttf.inc
@@ -0,0 +1,19 @@
+SECTION = "x11/fonts" #maybe this should be "fonts/ttf"?
+PRIORITY = "optional"
+PACKAGE_ARCH = "all"
+#DEPENDS = "fontconfig"
+#RSUGGESTS = "libfontconfig-utils"
+
+# I dont want TTF fonts to depend on fontconfig on device
+# as those fonts can be used not only in X11 enviroment
+# for example I use them with OPIE
+
+do_install() {
+ install -d ${D}${datadir}/fonts/truetype/
+ install -m 0644 ${S}/*.ttf ${D}${datadir}/fonts/truetype/
+}
+
+#pkg_postinst () {
+##!/bin/sh
+#fc-cache
+#}