aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ttf-fonts
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-06-07 09:29:28 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-06-07 09:29:28 +0000
commitd8858809bff2b9bf50f87c04e303e6b988ecf682 (patch)
tree759af90b26abcb7dd22a0392b1187f9eaf9276a0 /packages/ttf-fonts
parent1571a7edea7968de3469e0763c27f3231a6fe553 (diff)
downloadopenembedded-d8858809bff2b9bf50f87c04e303e6b988ecf682.tar.gz
move bitstream-vera fonts to ttf-fonts and qpf-fonts respectively.
Diffstat (limited to 'packages/ttf-fonts')
-rw-r--r--packages/ttf-fonts/ttf-bitstream-vera_1.10.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/ttf-fonts/ttf-bitstream-vera_1.10.bb b/packages/ttf-fonts/ttf-bitstream-vera_1.10.bb
new file mode 100644
index 0000000000..871bc1d37c
--- /dev/null
+++ b/packages/ttf-fonts/ttf-bitstream-vera_1.10.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "The Bitstream Vera fonts - TTF Edition"
+SECTION = "x11/fonts"
+PRIORITY = "optional"
+LICENSE = "Bitstream Vera"
+PACKAGE_ARCH = "all"
+PR = "r3"
+RDEPENDS = "fontconfig-utils"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
+
+do_install () {
+ install -d ${D}${prefix}/share/fonts/ttf/
+ for i in *.ttf; do
+ install -m 644 $i ${D}${prefix}/share/fonts/ttf/${i}
+ done
+
+ # fontconfig ships this too. not sure what to do about it.
+ #install -d ${D}${sysconfdir}/fonts
+ #install -m 644 local.conf ${D}${sysconfdir}/fonts/local.conf
+
+
+ install -d ${D}${prefix}/share/doc/${PN}/
+ for i in *.TXT; do
+ install -m 644 $i ${D}${prefix}/share/doc/${PN}/$i
+ done
+}
+
+pkg_postinst () {
+#!/bin/sh
+fc-cache
+}
+
+
+FILES_${PN} = "/etc ${datadir}/fonts"