aboutsummaryrefslogtreecommitdiffstats
path: root/packages/txdrug
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-08-04 21:46:10 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-08-04 21:46:10 +0000
commita957554d221fc9c5464d7685c63b9d6103809af5 (patch)
tree2c4aefb9ad4e35db0752b8d82489a8dcd28e44d9 /packages/txdrug
parent11329060327d787712fd51afcf6b574143a619e7 (diff)
downloadopenembedded-a957554d221fc9c5464d7685c63b9d6103809af5.tar.gz
txdrug: fix include path and incorrect assumptions about $palmtopdir. closes 2420.
Diffstat (limited to 'packages/txdrug')
-rw-r--r--packages/txdrug/txdrug_0.1.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/packages/txdrug/txdrug_0.1.bb b/packages/txdrug/txdrug_0.1.bb
index cd82234955..31da8117f7 100644
--- a/packages/txdrug/txdrug_0.1.bb
+++ b/packages/txdrug/txdrug_0.1.bb
@@ -3,10 +3,10 @@ SECTION = "opie/applications"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "sqlite"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://teax.sourceforge.net/txdrug-${PV}.tar.gz \
- file://${FILESDIR}/${palmtopdir}"
+ file://${FILESDIR}/opt/QtPalmtop"
S = "${WORKDIR}/txdrug-tar"
inherit palmtop
@@ -14,11 +14,16 @@ inherit palmtop
EXTRA_QMAKEVARS_POST += "LIBS+=-lsqlite TARGET=txdrug"
do_configure_prepend() {
- rm -f Makefile && qmake -project
+ rm -f Makefile && qmake -project
+}
+
+do_configure_append() {
+ sed -i "s/\-I\/usr\/include\/sqlite\ //g" Makefile
}
do_install() {
install -d ${D}${palmtopdir}
- cp -Pfr `ls -dp ${WORKDIR}/${palmtopdir}/*|grep -v SCCS` ${D}${palmtopdir}/
+ cp -Pfr `ls -dp ${WORKDIR}/opt/QtPalmtop/*|grep -v SCCS` ${D}${palmtopdir}/
install -D -m 755 txdrug ${D}${palmtopdir}/bin/txdrug
}
+