aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uboot
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-03-07 09:38:37 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-03-07 09:38:37 +0000
commit42f9ffa88b51752842deb20797feafd528b8e7b9 (patch)
tree5533868d9e2e1591f570b4469c86ab645d55d10f /packages/uboot
parent81f5b137a2f606ba7d95137fd18d501e8f67ca6b (diff)
downloadopenembedded-42f9ffa88b51752842deb20797feafd528b8e7b9.tar.gz
u-boot-mkimage-gta01: build uboot-mkimage needed for Neo1973 kernel
- same tool is built with uboot-gta01_svn.bb recipe but Neo1973 u-boot require OABI toolchain
Diffstat (limited to 'packages/uboot')
-rw-r--r--packages/uboot/u-boot-mkimage-gta01_svn.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/uboot/u-boot-mkimage-gta01_svn.bb b/packages/uboot/u-boot-mkimage-gta01_svn.bb
new file mode 100644
index 0000000000..ad98bea30e
--- /dev/null
+++ b/packages/uboot/u-boot-mkimage-gta01_svn.bb
@@ -0,0 +1,18 @@
+require uboot-gta01_svn.bb
+
+PROVIDES = ""
+TARGET_LDFLAGS = ""
+
+do_compile () {
+ chmod +x board/neo1973/split_by_variant.sh
+ oe_runmake gta01bv3_config
+ oe_runmake clean
+ oe_runmake tools
+}
+
+do_deploy () {
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile