aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uboot
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-03-02 22:41:25 +0000
committerChris Larson <clarson@kergoth.com>2005-03-02 22:41:25 +0000
commit47ca88395b85879bc0f3795af79681acbae978a9 (patch)
tree98407dfdc2581bc112b94ba8069987cabf566227 /packages/uboot
parent5968ea573e5bf0b4975ebac9d864ef9f99f38920 (diff)
downloadopenembedded-47ca88395b85879bc0f3795af79681acbae978a9.tar.gz
Do the u-boot binary deployment in a do_deploy task, like the kernels, and apply the arm flags patch to the base u-boot build.
BKrev: 42264115WcIT5BVuYeKTQKGTPy4QTw
Diffstat (limited to 'packages/uboot')
-rw-r--r--packages/uboot/uboot-vibren-pxa255idp_cvs.bb4
-rw-r--r--packages/uboot/uboot_cvs.bb32
2 files changed, 36 insertions, 0 deletions
diff --git a/packages/uboot/uboot-vibren-pxa255idp_cvs.bb b/packages/uboot/uboot-vibren-pxa255idp_cvs.bb
index e69de29bb2..870f330ac8 100644
--- a/packages/uboot/uboot-vibren-pxa255idp_cvs.bb
+++ b/packages/uboot/uboot-vibren-pxa255idp_cvs.bb
@@ -0,0 +1,4 @@
+include uboot_cvs.bb
+
+UBOOT_MACHINE = "pxa255_idp_config"
+SRC_URI += "ftp://bec-systems.com/pub/pxa255_idp/u-boot/uboot_pxa255-idp_2005-03-02.patch;patch=1"
diff --git a/packages/uboot/uboot_cvs.bb b/packages/uboot/uboot_cvs.bb
index e69de29bb2..67a05a9b25 100644
--- a/packages/uboot/uboot_cvs.bb
+++ b/packages/uboot/uboot_cvs.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "U-boot bootloader"
+SECTION = "bootloader"
+MAINTAINER = "Cliff Brake <cliff.brake@gmail.com>"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PV = "0.0cvs${CVSDATE}"
+PR = "r1"
+
+PROVIDES = "virtual/bootloader"
+
+S = "${WORKDIR}/u-boot"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/u-boot;module=u-boot \
+ file://arm_flags.patch;patch=1"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_LDFLAGS = ""
+UBOOT_MACHINE ?= "${MACHINE}"
+
+inherit base
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+}
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/u-boot.bin
+}
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile