aboutsummaryrefslogtreecommitdiffstats
path: root/packages/udev
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2008-02-10 01:52:20 +0000
committerMike Westerhof <mwester@dls.net>2008-02-10 01:52:20 +0000
commitce51a7c1cdf92c7848ef5bca186d794bcaeba0bd (patch)
treef999d9b1d70aaf5e3a8bcce0eeddc926126a9bd9 /packages/udev
parent9b74675469281deb29b565ec6d2a14e2c8418c56 (diff)
downloadopenembedded-ce51a7c1cdf92c7848ef5bca186d794bcaeba0bd.tar.gz
SlugOS: udev - do not attempt to mount a device via fstab since mounting on
SlugOS is done via UUID, not device names.
Diffstat (limited to 'packages/udev')
-rw-r--r--packages/udev/files/slugos/mount.sh77
-rw-r--r--packages/udev/udev_100.bb3
2 files changed, 79 insertions, 1 deletions
diff --git a/packages/udev/files/slugos/mount.sh b/packages/udev/files/slugos/mount.sh
new file mode 100644
index 0000000000..11714c1390
--- /dev/null
+++ b/packages/udev/files/slugos/mount.sh
@@ -0,0 +1,77 @@
+#!/bin/sh
+#
+# Called from udev
+# Attemp to mount any added block devices
+# and remove any removed devices
+#
+
+MOUNT="/bin/mount"
+PMOUNT="/usr/bin/pmount"
+UMOUNT="/bin/umount"
+name="`basename "$DEVNAME"`"
+
+for line in `cat /etc/udev/mount.blacklist | grep -v ^#`
+do
+ if ( echo "$DEVNAME" | grep -q "$line" )
+ then
+ logger "udev/mount.sh" "[$DEVNAME] is blacklisted, ignoring"
+ exit 0
+ fi
+done
+
+automount() {
+ ! test -d "/media/$name" && mkdir -p "/media/$name"
+
+ if ! $MOUNT -t auto -o sync $DEVNAME "/media/$name"
+ then
+ #logger "mount.sh/automount" "$MOUNT -t auto $DEVNAME \"/media/$name\" failed!"
+ rm_dir "/media/$name"
+ else
+ logger "mount.sh/automount" "Auto-mount of [/media/$name] successful"
+ touch "/tmp/.automount-$name"
+ fi
+}
+
+rm_dir() {
+ # We do not want to rm -r populated directories
+ if test "`find "$1" | wc -l | tr -d " "`" -lt 2 -a -d "$1"
+ then
+ ! test -z "$1" && rm -r "$1"
+ else
+ logger "mount.sh/automount" "Not removing non-empty directory [$1]"
+ fi
+}
+
+if [ "$ACTION" = "add" ] && [ -n "$DEVNAME" ]; then
+ # SlugOS: we pivot to the rootfs based on UUID, not on fstab -- so the fstab may not
+ # be correct at this point in the boot. So we must not let udev mount devices based
+ # soley on the fstab, lest we mount overtop the real rootfs. For now we just comment
+ # out the logic below and let the automount logic (far below) deal with all udev mount
+ # operations.
+ #if [ -x "$PMOUNT" ]; then
+ # $PMOUNT $DEVNAME 2> /dev/null
+ #elif [ -x $MOUNT ]; then
+ # $MOUNT $DEVNAME 2> /dev/null
+ #fi
+
+ # If the device isn't mounted at this point, it isn't configured in fstab
+ # 20061107: Small correction: The rootfs partition may be called just "rootfs" and not by
+ # its true device name so this would break. If the rootfs is mounted on two places
+ # during boot, it confuses the heck out of fsck. So Im auto-adding the root-partition
+ # to /etc/udev/mount.blacklist via postinst
+
+ cat /proc/mounts | awk '{print $1}' | grep -q "^$DEVNAME$" || automount
+
+fi
+
+
+
+if [ "$ACTION" = "remove" ] && [ -x "$UMOUNT" ] && [ -n "$DEVNAME" ]; then
+ for mnt in `cat /proc/mounts | grep "$DEVNAME" | cut -f 2 -d " " `
+ do
+ $UMOUNT $mnt
+ done
+
+ # Remove empty directories from auto-mounter
+ test -e "/tmp/.automount-$name" && rm_dir "/media/$name"
+fi
diff --git a/packages/udev/udev_100.bb b/packages/udev/udev_100.bb
index ac981bbe9c..c8840e1a8f 100644
--- a/packages/udev/udev_100.bb
+++ b/packages/udev/udev_100.bb
@@ -9,12 +9,13 @@ used to detect the type of a file system and read its metadata."
DESCRIPTION_libvolume-id-dev = "libvolume_id development headers, \
needed to link programs with libvolume_id."
-PR = "r10"
+PR = "r11"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
file://flags.patch;patch=1 \
file://mount.blacklist \
+ file://mount.sh \
"
require udev.inc