aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uicmoc
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-06 22:56:54 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-06 22:56:54 +0000
commit80820d3015bbadc30189a01cecc2a9187d088cad (patch)
treee7868e9811dbf68b6bb996a404e94c28acf49c06 /packages/uicmoc
parentbc40a3b09699a4e94346190305a16835d6bb4db5 (diff)
downloadopenembedded-80820d3015bbadc30189a01cecc2a9187d088cad.tar.gz
uicmoc 2.3.10, 3.3.5: add patch to make it build on 64bit platforms.
Thanks Darren Edmundson for writing the patch and Eric Shattow for testing. uicmoc3: fix a buglet in the 64bit-cleanup patch applied changes from b10f1ed461d73562b22f666803d0299ed187ca8a through 0d418c5552d13b58959ab3334bcae1de8f796828 applied changes from bdfe3d888ff9f0ac9b669e49dc70d55553650a79 through fdd0a90d3d11c8af63b9dd18e4f2ff096329e970
Diffstat (limited to 'packages/uicmoc')
-rw-r--r--packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch147
-rw-r--r--packages/uicmoc/uicmoc3-native_3.3.5.bb8
2 files changed, 152 insertions, 3 deletions
diff --git a/packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch b/packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch
new file mode 100644
index 0000000000..17836802a6
--- /dev/null
+++ b/packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch
@@ -0,0 +1,147 @@
+--- qt-embedded-free-3.3.5/src/embedded/qgfxlinuxfb_qws.cpp~64bit 2005-12-14 15:51:23.000000000 +0000
++++ qt-embedded-free-3.3.5/src/embedded/qgfxlinuxfb_qws.cpp 2005-12-14 15:52:29.000000000 +0000
+@@ -176,7 +176,7 @@
+ MAP_SHARED, fd, 0);
+ data += dataoffset;
+
+- if ((int)data == -1) {
++ if ((intptr_t)data == -1) {
+ perror("mapping /dev/fb0");
+ qWarning("Error: failed to map framebuffer device to memory.");
+ return FALSE;
+@@ -737,7 +737,7 @@
+ psize += 8; // for alignment
+ psize &= ~0x7; // align
+
+- unsigned int pos=(unsigned int)data;
++ uintptr_t pos=(uintptr_t)data;
+ pos += psize;
+ entryp = ((int *)pos);
+ lowest = ((unsigned int *)pos)+1;
+--- qt-embedded-free-3.3.5/src/kernel/qsharedmemory_p.cpp~64bit 2005-12-14 15:34:43.000000000 +0000
++++ qt-embedded-free-3.3.5/src/kernel/qsharedmemory_p.cpp 2005-12-14 15:35:26.000000000 +0000
+@@ -31,6 +31,7 @@
+ **********************************************************************/
+
+ #include "qsharedmemory_p.h"
++#include <stdint.h>
+
+ #if !defined(QT_QWS_NO_SHM)
+
+@@ -132,7 +133,7 @@
+ shmId = shmget (key, shmSize, 0);
+
+ shmBase = shmat (shmId, 0, 0);
+- if ((int) shmBase == -1 || shmBase == 0)
++ if ((intptr_t) shmBase == -1 || shmBase == 0)
+ return FALSE;
+ else
+ return TRUE;
+--- qt-embedded-free-3.3.5/src/kernel/qapplication_qws.cpp~64bit 2005-12-14 15:27:14.000000000 +0000
++++ qt-embedded-free-3.3.5/src/kernel/qapplication_qws.cpp 2005-12-14 15:28:37.000000000 +0000
+@@ -107,6 +107,7 @@
+ #include <locale.h>
+ #include <errno.h>
+ #include <sys/time.h>
++#include <stdint.h>
+
+ #if defined(Q_OS_QNX)
+ #include <sys/select.h>
+@@ -1879,7 +1880,7 @@
+ w = widgetAt(*qt_last_x, *qt_last_y, FALSE);
+ if ( !w )
+ w = desktop();
+- QPaintDevice::qwsDisplay()->selectCursor(w, (int)app_cursor->handle());
++ QPaintDevice::qwsDisplay()->selectCursor(w, (intptr_t)app_cursor->handle());
+ }
+
+ void QApplication::restoreOverrideCursor()
+@@ -1898,11 +1899,11 @@
+ cursorStack = 0;
+ qws_overrideCursor = FALSE;
+ if ( w->testWState(WState_OwnCursor) )
+- QPaintDevice::qwsDisplay()->selectCursor(w, (int)w->cursor().handle());
++ QPaintDevice::qwsDisplay()->selectCursor(w, (intptr_t)w->cursor().handle());
+ else
+ QPaintDevice::qwsDisplay()->selectCursor(w, ArrowCursor);
+ } else {
+- QPaintDevice::qwsDisplay()->selectCursor(w, (int)app_cursor->handle());
++ QPaintDevice::qwsDisplay()->selectCursor(w, (intptr_t)app_cursor->handle());
+ }
+ }
+ #endif// QT_NO_CURSOR
+@@ -2130,7 +2131,7 @@
+ }
+ if ( !qws_overrideCursor ) {
+ if (curs)
+- QPaintDevice::qwsDisplay()->selectCursor(widget, (int)curs->handle());
++ QPaintDevice::qwsDisplay()->selectCursor(widget, (intptr_t)curs->handle());
+ else
+ QPaintDevice::qwsDisplay()->selectCursor(widget, ArrowCursor);
+ }
+--- qt-embedded-free-3.3.5/src/kernel/qfont_qws.cpp~64bit 2005-12-14 15:29:17.000000000 +0000
++++ qt-embedded-free-3.3.5/src/kernel/qfont_qws.cpp 2005-12-14 15:29:54.000000000 +0000
+@@ -49,6 +49,7 @@
+ #include "qgfx_qws.h"
+ #include "qtextengine_p.h"
+ #include "qfontengine_p.h"
++#include <stdint.h>
+
+ QFont::Script QFontPrivate::defaultScript = QFont::UnknownScript;
+
+@@ -133,7 +134,7 @@
+ req.pointSize = req.pixelSize*10;
+
+ if ( ! engineData ) {
+- QFontCache::Key key( req, QFont::NoScript, (int)paintdevice );
++ QFontCache::Key key( req, QFont::NoScript, (intptr_t)paintdevice );
+
+ // look for the requested font in the engine data cache
+ engineData = QFontCache::instance->findEngineData( key );
+--- qt-embedded-free-3.3.5/src/kernel/qwsregionmanager_qws.cpp~64bit 2005-12-14 15:32:12.000000000 +0000
++++ qt-embedded-free-3.3.5/src/kernel/qwsregionmanager_qws.cpp 2005-12-14 15:32:52.000000000 +0000
+@@ -32,6 +32,7 @@
+ #include "qwsdisplay_qws.h"
+ #include "qwsregionmanager_qws.h"
+ #include <stdlib.h>
++#include <stdint.h>
+
+ #ifndef QT_NO_QWS_MULTIPROCESS
+ #include <sys/types.h>
+@@ -288,7 +289,7 @@
+ data = (unsigned char *)shmat( shmId, 0, 0 );
+ }
+
+- return ( shmId != -1 && (int)data != -1 );
++ return ( shmId != -1 && (intptr_t)data != -1 );
+ #else
+ int dataSize = sizeof(QWSRegionHeader) // header
+ + sizeof(QWSRegionIndex) * QT_MAX_REGIONS // + index
+--- qt-embedded-free-3.3.5/src/kernel/qwidget_qws.cpp~64bit 2005-12-14 15:30:36.000000000 +0000
++++ qt-embedded-free-3.3.5/src/kernel/qwidget_qws.cpp 2005-12-14 15:31:37.000000000 +0000
+@@ -53,6 +53,7 @@
+ #include "qwsmanager_qws.h"
+ #include "qwsregionmanager_qws.h"
+ #include "qinputcontext_p.h"
++#include <stdint.h>
+
+ void qt_insert_sip( QWidget*, int, int ); // defined in qapplication_x11.cpp
+ int qt_sip_count( QWidget* ); // --- "" ---
+@@ -631,7 +632,7 @@
+ qt_mouseGrb->releaseMouse();
+
+ qwsDisplay()->grabMouse(this,TRUE);
+- qwsDisplay()->selectCursor(this, (unsigned int)cursor.handle());
++ qwsDisplay()->selectCursor(this, (uintptr_t)cursor.handle());
+ qt_mouseGrb = this;
+ qt_pressGrab = 0;
+ }
+@@ -1845,7 +1846,7 @@
+ QSize s( qt_screen->width(), qt_screen->height() );
+ QPoint pos = qt_screen->mapToDevice(QPoint(*qt_last_x, *qt_last_y), s);
+ if ( r.contains(pos) )
+- qwsDisplay()->selectCursor((QWidget*)this, (unsigned int)cursor().handle());
++ qwsDisplay()->selectCursor((QWidget*)this, (uintptr_t)cursor().handle());
+ }
+ }
+ #endif
diff --git a/packages/uicmoc/uicmoc3-native_3.3.5.bb b/packages/uicmoc/uicmoc3-native_3.3.5.bb
index 6354377bcf..d75b9c889b 100644
--- a/packages/uicmoc/uicmoc3-native_3.3.5.bb
+++ b/packages/uicmoc/uicmoc3-native_3.3.5.bb
@@ -1,12 +1,14 @@
DESCRIPTION = "User Interface Generator and Meta Object Compiler (moc) for Qt(E) 3.x"
+HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL QPL"
-PR = "r1"
+PR = "r3"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-free-${PV}.tar.bz2 \
- file://no-examples.patch;patch=1"
-
+ file://no-examples.patch;patch=1 \
+ file://64bit-cleanup.patch;patch=1"
S = "${WORKDIR}/qt-embedded-free-${PV}"
inherit native qmake-base qt3e