aboutsummaryrefslogtreecommitdiffstats
path: root/packages/unzip
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-09 23:40:15 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-09 23:40:15 +0000
commit00dd89ffdcf3b51fe5b8e2934fdd6bfa45694cbf (patch)
tree36937386b2c677b1e1d883bf67fe78eeebf44071 /packages/unzip
parent8aa7fe1751f4e90781b7aa1b9237ad266001bd05 (diff)
downloadopenembedded-00dd89ffdcf3b51fe5b8e2934fdd6bfa45694cbf.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/10 00:59:24+02:00 dyndns.org!reenoo Merge oe-devel@oe-devel.bkbits.net:openembedded into sugarcube.dyndns.org:/home2/oe/bakery/openembedded 2005/06/10 00:59:05+02:00 dyndns.org!reenoo unzip: use oe_runmake rather than make so that CC is set properly etc. install man pages to ${D}${mandir}. Fixes bug #45. 2005/06/09 23:37:48+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/06/09 23:33:06+01:00 reciva.com!pb new and updated jlime files, per bug #39 BKrev: 42a8d35fc22KrpkUSU0N3g-Gc5kctQ
Diffstat (limited to 'packages/unzip')
-rw-r--r--packages/unzip/unzip_552.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/packages/unzip/unzip_552.bb b/packages/unzip/unzip_552.bb
index c873d734ce..ead9624d93 100644
--- a/packages/unzip/unzip_552.bb
+++ b/packages/unzip/unzip_552.bb
@@ -1,16 +1,21 @@
DESCRIPTION = "A (de)compression library for the ZIP format"
SECTION = "console/utils"
LICENSE = "Info-ZIP"
+PR = "r1"
SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip${PV}.tar.gz"
S = "${WORKDIR}/unzip-5.52"
+export LD = "${CC}"
+
do_compile() {
- make -f unix/Makefile generic
+ oe_runmake -f unix/Makefile generic
}
do_install() {
- make -f unix/Makefile install prefix=${D}${prefix}
+ oe_runmake -f unix/Makefile install prefix=${D}${prefix}
+ install -d ${D}${mandir}
+ mv ${D}${prefix}/man/* ${D}${mandir}
}