aboutsummaryrefslogtreecommitdiffstats
path: root/packages/upslug/upslug-native_1.0.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-06-17 00:56:00 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-06-17 00:56:00 +0000
commitd8815b187088d9e54e656811e5efdc560a0823b2 (patch)
treedc2f36e56df0a0489233267a7ed9021f954c0108 /packages/upslug/upslug-native_1.0.bb
parent48b020d5d0a617a001924b5e812d943c0f6b7775 (diff)
downloadopenembedded-d8815b187088d9e54e656811e5efdc560a0823b2.tar.gz
Correct license and SRC_URI in upslug-native, change
preferences to use the 1.0 version not the CVS version. BKrev: 42b21fa0rzr_Q6_kprmS0YTh72HnTw
Diffstat (limited to 'packages/upslug/upslug-native_1.0.bb')
-rw-r--r--packages/upslug/upslug-native_1.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/upslug/upslug-native_1.0.bb b/packages/upslug/upslug-native_1.0.bb
index e69de29bb2..6f76bbe738 100644
--- a/packages/upslug/upslug-native_1.0.bb
+++ b/packages/upslug/upslug-native_1.0.bb
@@ -0,0 +1,35 @@
+# This package builds the 'upslug' binary upload/flash tool
+# for the NSLU2. It is not useful for anything else.
+PR = "r0"
+DESCRIPTION = "NSLU2 binary upload tool"
+HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug"
+MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL-2"
+
+SRC_TAG = "UPSLUG_${@'_'.join(bb.data.getVar('PV',d,1).split('.'))}"
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug;tag=${SRC_TAG}"
+# For testing use this (tags and other changes take a day to
+# propogate on sourceforge). Change 'jbowler' to your login name!
+#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/nslu;method=ext;rsh=ssh;tag=${SRC_TAG};module=upslug"
+
+inherit native
+
+S = "${WORKDIR}/upslug"
+
+# Dumb compile script
+do_compile() {
+ oe_runmake "CC=${CC}" "CFLAGS=${CFLAGS}"
+}
+
+do_stage() {
+ oe_runmake "DESTDIR=${STAGING_BINDIR}" install
+}
+
+python () {
+ # Don't build upslug unless we're targeting an nslu2
+ mach = bb.data.getVar("MACHINE", d, 1)
+ if mach != 'nslu2':
+ raise bb.parse.SkipPackage("upslug only builds for the Linksys NSLU2")
+}