aboutsummaryrefslogtreecommitdiffstats
path: root/packages/usrp
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-01-09 21:11:38 +0000
committerPhilip Balister <philip@balister.org>2007-01-09 21:11:38 +0000
commit69bde32a9397cfb9bc224611ccf5cff6ccb3ffef (patch)
treebeb3e4bd2064488ff86264195763fab1486efef7 /packages/usrp
parent9b2b3dc9b51de3a41fd5546f8a91900cdfbd7f17 (diff)
downloadopenembedded-69bde32a9397cfb9bc224611ccf5cff6ccb3ffef.tar.gz
usrp_0.12.bb : Fix compile.h header file problem.
Add hack so it links on EFIKA/powerpc.
Diffstat (limited to 'packages/usrp')
-rw-r--r--packages/usrp/files/fix_compile_h.patch13
-rw-r--r--packages/usrp/usrp_0.12.bb5
2 files changed, 17 insertions, 1 deletions
diff --git a/packages/usrp/files/fix_compile_h.patch b/packages/usrp/files/fix_compile_h.patch
new file mode 100644
index 0000000000..02ba7e44a0
--- /dev/null
+++ b/packages/usrp/files/fix_compile_h.patch
@@ -0,0 +1,13 @@
+Index: gnuradio/trunk/usrp/host/lib/fusb_linux.cc
+===================================================================
+--- gnuradio/trunk/usrp/host/lib/fusb_linux.cc (revision 3534)
++++ gnuradio/trunk/usrp/host/lib/fusb_linux.cc (revision 3886)
+@@ -28,5 +28,7 @@
+ #include <usb.h> // libusb header
+ #include <stdexcept>
++#ifdef HAVE_LINUX_COMPILER_H
+ #include <linux/compiler.h>
++#endif
+ #include <linux/usbdevice_fs.h> // interface to kernel portion of user mode usb driver
+ #include <sys/ioctl.h>
+
diff --git a/packages/usrp/usrp_0.12.bb b/packages/usrp/usrp_0.12.bb
index 5fc6969f8c..ade37baf60 100644
--- a/packages/usrp/usrp_0.12.bb
+++ b/packages/usrp/usrp_0.12.bb
@@ -7,13 +7,16 @@ RDEPENDS = "python-core"
PR = "r0"
SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/usrp-${PV}.tar.gz \
- file://usb11.patch;patch=1" \
+ file://usb11.patch;patch=1 \
+ file://fix_compile_h.patch;patch=1;pnum=3 \
file://install_test.patch;patch=1"
S = "${WORKDIR}/usrp-${PV}"
inherit autotools pkgconfig
+CXXFLAGS_powerpc += "-lstdc++"
+
export BUILD_SYS := "${BUILD_SYS}"
export HOST_SYS := "${HOST_SYS}"