aboutsummaryrefslogtreecommitdiffstats
path: root/packages/usrp
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2006-10-19 19:17:41 +0000
committerPhilip Balister <philip@balister.org>2006-10-19 19:17:41 +0000
commitc6d2b76c9ce1609f1e7be9546fd2d0031447251e (patch)
tree85712b64aa89437cc7e6a521cfded91aeaa302f7 /packages/usrp
parent2a707b232b5a65e7c7a76649f90c1390e438da60 (diff)
downloadopenembedded-c6d2b76c9ce1609f1e7be9546fd2d0031447251e.tar.gz
usrp : Update bb file to use 0.12 version. Start fixing build process.
Diffstat (limited to 'packages/usrp')
-rw-r--r--packages/usrp/usrp_0.12.bb (renamed from packages/usrp/usrp_0.8.bb)7
1 files changed, 5 insertions, 2 deletions
diff --git a/packages/usrp/usrp_0.8.bb b/packages/usrp/usrp_0.12.bb
index 16059186d0..a057eb2e4c 100644
--- a/packages/usrp/usrp_0.8.bb
+++ b/packages/usrp/usrp_0.12.bb
@@ -2,14 +2,17 @@ DESCRIPTION = "Support software for the Universal Software Radio Peripheral (USR
LICENSE = "GPL"
HOMEPAGE = "http://comsec.com/wiki?UniversalSoftwareRadioPeripheral"
SECTION = "devel"
-DEPENDS = "swig-native sdcc-native libusb"
+DEPENDS = "swig-native sdcc-native libusb python python-native"
PR = "r0"
SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/usrp-${PV}.tar.gz \
file://usb11.patch;patch=1"
S = "${WORKDIR}/usrp-${PV}"
-inherit autotools
+inherit autotools pkgconfig
+
+export BUILD_SYS := "${BUILD_SYS}"
+export HOST_SYS := "${HOST_SYS}"
do_stage () {
oe_libinstall -so -C host/lib/.libs/ libusrp ${STAGING_LIBDIR}