aboutsummaryrefslogtreecommitdiffstats
path: root/packages/usrp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/usrp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/usrp')
-rw-r--r--packages/usrp/files/fix_compile_h.patch13
-rw-r--r--packages/usrp/files/install_test.patch20
-rw-r--r--packages/usrp/files/usb11.patch96
-rw-r--r--packages/usrp/usrp_0.12.bb41
4 files changed, 0 insertions, 170 deletions
diff --git a/packages/usrp/files/fix_compile_h.patch b/packages/usrp/files/fix_compile_h.patch
deleted file mode 100644
index 02ba7e44a0..0000000000
--- a/packages/usrp/files/fix_compile_h.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: gnuradio/trunk/usrp/host/lib/fusb_linux.cc
-===================================================================
---- gnuradio/trunk/usrp/host/lib/fusb_linux.cc (revision 3534)
-+++ gnuradio/trunk/usrp/host/lib/fusb_linux.cc (revision 3886)
-@@ -28,5 +28,7 @@
- #include <usb.h> // libusb header
- #include <stdexcept>
-+#ifdef HAVE_LINUX_COMPILER_H
- #include <linux/compiler.h>
-+#endif
- #include <linux/usbdevice_fs.h> // interface to kernel portion of user mode usb driver
- #include <sys/ioctl.h>
-
diff --git a/packages/usrp/files/install_test.patch b/packages/usrp/files/install_test.patch
deleted file mode 100644
index d24cfb5191..0000000000
--- a/packages/usrp/files/install_test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- usrp-0.12.orig/host/apps/Makefile.am 2006-04-03 18:52:05.000000000 -0400
-+++ usrp-0.12/host/apps/Makefile.am 2006-10-20 16:15:02.000000000 -0400
-@@ -23,13 +23,13 @@
-
- bin_PROGRAMS = \
- usrper \
-- usrp_cal_dc_offset
--
--noinst_PROGRAMS = \
-- check_order_quickly \
-+ usrp_cal_dc_offset \
- test_usrp_standard_rx \
- test_usrp_standard_tx
-
-+noinst_PROGRAMS = \
-+ check_order_quickly
-+
- noinst_HEADERS = \
- time_stuff.h
-
diff --git a/packages/usrp/files/usb11.patch b/packages/usrp/files/usb11.patch
deleted file mode 100644
index a0f1f548a6..0000000000
--- a/packages/usrp/files/usb11.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-diff -ur usrp-0.8/firmware/include/fpga_regs_standard.h usrp-0.8-usb11/firmware/include/fpga_regs_standard.h
---- usrp-0.8/firmware/include/fpga_regs_standard.h 2004-12-10 23:25:42.000000000 -0500
-+++ usrp-0.8-usb11/firmware/include/fpga_regs_standard.h 2005-04-18 15:48:58.000000000 -0400
-@@ -103,6 +103,7 @@
- // 3 chan 1 Q
-
- #define FR_TX_MUX 39
-+#define FR_USB_PACKET_SIZE 40
-
- #endif /* INCLUDED_FPGA_REGS_STANDARD_H */
-
-diff -ur usrp-0.8/firmware/src/common/usrp_common.c usrp-0.8-usb11/firmware/src/common/usrp_common.c
---- usrp-0.8/firmware/src/common/usrp_common.c 2004-03-28 17:28:58.000000000 -0500
-+++ usrp-0.8-usb11/firmware/src/common/usrp_common.c 2005-04-17 12:10:26.000000000 -0400
-@@ -101,9 +101,13 @@
- // set autoin length for EP6
- // FIXME should be f(enumeration)
-
-- EP6AUTOINLENH = (512) >> 8; SYNCDELAY; // this is the length for high speed
-- EP6AUTOINLENL = (512) & 0xff; SYNCDELAY;
--
-+ if (USBCS & bmHSM) {
-+ EP6AUTOINLENH = (512) >> 8; SYNCDELAY; // this is the length for high speed
-+ EP6AUTOINLENL = (512) & 0xff; SYNCDELAY;
-+ } else {
-+ EP6AUTOINLENH = (64) >> 8; SYNCDELAY; // this is the length for full speed
-+ EP6AUTOINLENL = (64) & 0xff; SYNCDELAY;
-+ }
- init_board ();
- }
-
-diff -ur usrp-0.8/firmware/src/usrp2/usb_descriptors.a51 usrp-0.8-usb11/firmware/src/usrp2/usb_descriptors.a51
---- usrp-0.8/firmware/src/usrp2/usb_descriptors.a51 2004-12-08 16:11:24.000000000 -0500
-+++ usrp-0.8-usb11/firmware/src/usrp2/usb_descriptors.a51 2005-04-14 11:51:07.000000000 -0400
-@@ -236,7 +236,7 @@
- .db DSCR_CONFIG
- .db <(_full_speed_config_descr_end - _full_speed_config_descr) ; LSB
- .db >(_full_speed_config_descr_end - _full_speed_config_descr) ; MSB
-- .db 1 ; bNumInterfaces
-+ .db 3 ; bNumInterfaces
- .db 1 ; bConfigurationValue
- .db 0 ; iConfiguration
- .db 0x80 | bmSELF_POWERED ; bmAttributes
-@@ -253,7 +253,53 @@
- .db 0xff ; bInterfaceSubClass (vendor specific)
- .db 0xff ; bInterfaceProtocol (vendor specific)
- .db SI_COMMAND_AND_STATUS ; iInterface (description)
-+
-+ ;; interface descriptor 1 (transmit path, ep2 OUT BULK)
-+
-+ .db DSCR_INTRFC_LEN
-+ .db DSCR_INTRFC
-+ .db 1 ; bInterfaceNumber (zero based)
-+ .db 0 ; bAlternateSetting
-+ .db 1 ; bNumEndpoints
-+ .db 0xff ; bInterfaceClass (vendor specific)
-+ .db 0xff ; bInterfaceSubClass (vendor specific)
-+ .db 0xff ; bInterfaceProtocol (vendor specific)
-+ .db SI_TX_PATH ; iInterface (description)
-+
-+ ;; interface 1's end point
-+
-+ .db DSCR_ENDPNT_LEN
-+ .db DSCR_ENDPNT
-+ .db 0x02 ; bEndpointAddress (ep 2 OUT)
-+ .db ET_BULK ; bmAttributes
-+ .db <64 ; wMaxPacketSize (LSB)
-+ .db >64 ; wMaxPacketSize (MSB)
-+ .db 0 ; bInterval (iso only)
-+
-+ ;; interface descriptor 2 (receive path, ep6 IN BULK)
-+
-+ .db DSCR_INTRFC_LEN
-+ .db DSCR_INTRFC
-+ .db 2 ; bInterfaceNumber (zero based)
-+ .db 0 ; bAlternateSetting
-+ .db 1 ; bNumEndpoints
-+ .db 0xff ; bInterfaceClass (vendor specific)
-+ .db 0xff ; bInterfaceSubClass (vendor specific)
-+ .db 0xff ; bInterfaceProtocol (vendor specific)
-+ .db SI_RX_PATH ; iInterface (description)
-+
-+ ;; interface 2's end point
-+
-+ .db DSCR_ENDPNT_LEN
-+ .db DSCR_ENDPNT
-+ .db 0x86 ; bEndpointAddress (ep 6 IN)
-+ .db ET_BULK ; bmAttributes
-+ .db <64 ; wMaxPacketSize (LSB)
-+ .db >64 ; wMaxPacketSize (MSB)
-+ .db 0 ; bInterval (iso only)
-+
-
-+
- _full_speed_config_descr_end:
-
diff --git a/packages/usrp/usrp_0.12.bb b/packages/usrp/usrp_0.12.bb
deleted file mode 100644
index 55ca84857a..0000000000
--- a/packages/usrp/usrp_0.12.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "Support software for the Universal Software Radio Peripheral (USRP)"
-LICENSE = "GPL"
-HOMEPAGE = "http://comsec.com/wiki?UniversalSoftwareRadioPeripheral"
-SECTION = "devel"
-DEPENDS = "swig-native sdcc-native libusb-compat python boost"
-RDEPENDS = "python-core"
-PR = "r1"
-
-SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/usrp-${PV}.tar.gz \
- file://fix_compile_h.patch;patch=1;pnum=3 \
- file://install_test.patch;patch=1"
-
-SRC_URI_append_omap5912osk = "file://usb11.patch;patch=1"
-
-S = "${WORKDIR}/usrp-${PV}"
-
-inherit autotools pkgconfig
-
-CXXFLAGS_powerpc += "-lstdc++"
-
-export BUILD_SYS := "${BUILD_SYS}"
-export HOST_SYS := "${HOST_SYS}"
-
-do_stage () {
- oe_libinstall -so -C host/lib/.libs/ libusrp ${STAGING_LIBDIR}
-
- install -m 644 host/lib/usrp_basic.h ${STAGING_INCDIR}
- install -m 644 host/lib/usrp_bytesex.h ${STAGING_INCDIR}
- install -m 644 host/lib/usrp_config.h ${STAGING_INCDIR}
- install -m 644 host/lib/usrp_dbid.h ${STAGING_INCDIR}
- install -m 644 host/lib/usrp_prims.h ${STAGING_INCDIR}
- install -m 644 host/lib/usrp_slots.h ${STAGING_INCDIR}
- install -m 644 host/lib/usrp_standard.h ${STAGING_INCDIR}
-
- install -m 644 firmware/include/usrp_i2c_addr.h ${STAGING_INCDIR}
- install -m 644 firmware/include/usrp_spi_defs.h ${STAGING_INCDIR}
-}
-
-PACKAGES += "python-pyusrp-dbg python-pyusrp"
-FILES_python-pyusrp-dbg += "${libdir}/python*/site-packages/.debug"
-FILES_python-pyusrp = "${libdir}/python*"