aboutsummaryrefslogtreecommitdiffstats
path: root/packages/vim
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-10-31 22:41:11 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-31 22:41:11 +0000
commitef9362fe201af92671aa7550e03f2fb4fe83d5f1 (patch)
tree54c923bad5451b5fefc937501f608836d149ce94 /packages/vim
parente4223fb92daa8103e0da135aa2dabff4469935f7 (diff)
downloadopenembedded-ef9362fe201af92671aa7550e03f2fb4fe83d5f1.tar.gz
vim 6.4: reorganization and split into more packages
- moved common part into vim.inc - new packages: - vim-syntax with /usr/share/vim/vimXX/syntax/ (2.8M) - vim-help with "online" help (4.1M) - vim-tutor (0.6M) More work can be done on vim but this is good step.
Diffstat (limited to 'packages/vim')
-rw-r--r--packages/vim/vim-tiny_6.4.bb7
-rw-r--r--packages/vim/vim.inc30
-rw-r--r--packages/vim/vim_6.4.bb23
3 files changed, 34 insertions, 26 deletions
diff --git a/packages/vim/vim-tiny_6.4.bb b/packages/vim/vim-tiny_6.4.bb
index 897e40dddd..16f60693fa 100644
--- a/packages/vim/vim-tiny_6.4.bb
+++ b/packages/vim/vim-tiny_6.4.bb
@@ -1,12 +1,9 @@
-SECTION = "console/utils"
include vim_${PV}.bb
+
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/vim-${PV}"
-LICENSE = "vim"
+
EXTRA_OECONF = "--enable-gui=none --disable-gtktest \
--disable-xim --with-features=tiny \
--disable-gpm --without-x --disable-netbeans \
--with-tlib=ncurses"
-FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
- ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
- /bin /sbin /lib/*/ /lib/*.so* ${datadir}/vim"
diff --git a/packages/vim/vim.inc b/packages/vim/vim.inc
new file mode 100644
index 0000000000..f675ce839f
--- /dev/null
+++ b/packages/vim/vim.inc
@@ -0,0 +1,30 @@
+DESCRIPTION = "Vim is an almost fully-compatible version of the Unix editor Vi."
+SECTION = "console/utils"
+DEPENDS = "ncurses"
+LICENSE = "vim"
+
+SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+S = "${WORKDIR}/vim${VIMVER}/src"
+
+inherit autotools
+
+do_configure () {
+ rm -f auto/*
+ touch auto/config.mk
+ aclocal
+ autoconf
+ oe_runconf
+ touch auto/configure
+ touch auto/config.mk auto/config.h
+}
+
+PACKAGES =+ "vim-common vim-syntax vim-help vim-tutor"
+FILES_vim-syntax = "${datadir}/vim/vim${VIMVER}/syntax"
+FILES_vim-help = "${datadir}/vim/vim${VIMVER}/doc"
+FILES_vim-tutor = "${datadir}/vim/vim${VIMVER}/tutor ${bindir}/vimtutor"
+
+#FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
+# ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+# /bin /sbin /lib/*/ /lib/*.so* ${datadir}/vim"
diff --git a/packages/vim/vim_6.4.bb b/packages/vim/vim_6.4.bb
index 1740a465a3..b53c752529 100644
--- a/packages/vim/vim_6.4.bb
+++ b/packages/vim/vim_6.4.bb
@@ -1,28 +1,9 @@
-DESCRIPTION = "Vim is an almost fully-compatible version of the Unix editor Vi."
-SECTION = "console/utils"
-DEPENDS = "ncurses"
-LICENSE = "vim"
+VIMVER = "64"
-SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
- file://configure.patch;patch=1"
-
-S = "${WORKDIR}/vim64/src"
-
-inherit autotools
+include vim.inc
EXTRA_OECONF = "--enable-gui=none --disable-gtktest \
--disable-xim --with-features=normal \
--disable-gpm --without-x --disable-netbeans \
--with-tlib=ncurses"
-do_configure () {
- rm -f auto/*
- touch auto/config.mk
- aclocal
- autoconf
- oe_runconf
- touch auto/configure
- touch auto/config.mk auto/config.h
-}
-
-#FILES_${PN}-doc=${datadir}/vim/vim64/doc ${mandir} ${infodir}