aboutsummaryrefslogtreecommitdiffstats
path: root/packages/webkit
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-30 10:40:10 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-30 10:40:10 +0000
commit0535783ac5c2439e33959ee3598f99ba8805053e (patch)
treebfe753e19e49fbbd3c0af5037481bebd11a8c5c8 /packages/webkit
parent16c55f06c1bcb160697c5465f30434f3b26fede1 (diff)
downloadopenembedded-0535783ac5c2439e33959ee3598f99ba8805053e.tar.gz
webkit: unbreak qmake usage a bit
Diffstat (limited to 'packages/webkit')
-rw-r--r--packages/webkit/webkit_svn.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/packages/webkit/webkit_svn.bb b/packages/webkit/webkit_svn.bb
index 7e221f4113..e86cfac6ac 100644
--- a/packages/webkit/webkit_svn.bb
+++ b/packages/webkit/webkit_svn.bb
@@ -1,4 +1,4 @@
-DEPENDS = "flex-native icu uicmoc4-native qmake2-native libxml2 sqlite3 cairo gtk+"
+DEPENDS = "flex-native curl icu uicmoc4-native qmake2-native libxml2 sqlite3 cairo gtk+"
# Yes, this is wrong...
PV = "0.0+svn${SRCDATE}"
@@ -22,14 +22,13 @@ SRC_URI = "\
S = "${WORKDIR}/"
-do_configure() {
- qmake2 CONFIG+=gdk-port CONFIG-=qt CONFIG-=release CONFIG+=debug
+do_configure_append() {
+ qmake2 -spec ${QMAKESPEC} CONFIG+=gdk-port CONFIG-=qt CONFIG-=release CONFIG+=debug
mkdir -p WebKitBuilds/Debug
cd WebKitBuilds/Debug
- PWD=`pwd` qmake2 -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro
+ PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro
}
-do_compile() {
+do_compile_prepend() {
cd ${S}/WebKitBuilds/Debug
- oe_runmake
}