aboutsummaryrefslogtreecommitdiffstats
path: root/packages/webkit
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-07-31 23:46:06 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-07-31 23:46:06 +0000
commita26a9fc2d2158f4881adf3b3511aa951fc27a8b9 (patch)
tree6575947ec9eebed7a5a068f069f689fa126800f9 /packages/webkit
parentde7ec2487e46e7ff12950717d7e575c6b8301c96 (diff)
downloadopenembedded-a26a9fc2d2158f4881adf3b3511aa951fc27a8b9.tar.gz
webkit: clean up (guys, please don't mix TABs and SPACEs) and make it build
Diffstat (limited to 'packages/webkit')
-rw-r--r--packages/webkit/webkit_svn.bb63
1 files changed, 30 insertions, 33 deletions
diff --git a/packages/webkit/webkit_svn.bb b/packages/webkit/webkit_svn.bb
index c5f5dcafa7..8a6480d54f 100644
--- a/packages/webkit/webkit_svn.bb
+++ b/packages/webkit/webkit_svn.bb
@@ -4,38 +4,37 @@ DEPENDS = "flex-native gperf-native gperf perl-native curl icu uicmoc4-native qm
PV = "0.0+svn${SRCDATE}"
PR = "r1"
-inherit qmake pkgconfig
+inherit qmake qt4x11 pkgconfig
SRC_URI = "\
- svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
-# svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitQt;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
- file://Makefile \
- file://Makefile.shared \
- file://WebKit.pri \
- file://WebKit.pro \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
+# svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitQt;proto=http \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
+ file://Makefile \
+ file://Makefile.shared \
+ file://WebKit.pri \
+ file://WebKit.pro \
"
-
S = "${WORKDIR}/"
-
do_configure_append() {
- qmake2 -spec ${QMAKESPEC} CONFIG+=gdk-port CONFIG-=qt CONFIG-=release CONFIG+=debug
+ qmake2 -spec ${QMAKESPEC} CONFIG+=gdk-port CONFIG-=qt CONFIG-=release CONFIG+=debug
mkdir -p WebKitBuilds/Debug
cd WebKitBuilds/Debug
- PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro WEBKIT_INC_DIR=${prefix}/include WEBKIT_LIB_DIR=${libdir}
+ PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro \
+ WEBKIT_INC_DIR=${prefix}/include WEBKIT_LIB_DIR=${libdir}
}
do_compile_prepend() {
- mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
- cd ${S}/JavaScriptCore/pcre
- ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
- cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
- cd ${S}/WebKitBuilds/Debug
+ mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
+ cd ${S}/JavaScriptCore/pcre
+ ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
+ cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
+ cd ${S}/WebKitBuilds/Debug
}
do_install() {
@@ -44,24 +43,22 @@ do_install() {
install -d ${D}${libdir}/pkgconfig
install -m 0755 ${S}/WebKitBuilds/Debug/WebKitTools/GdkLauncher/GdkLauncher ${D}${bindir}
- cd ${S}/WebKitBuilds/Debug
- PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro WEBKIT_INC_DIR=${D}${prefix}/include WEBKIT_LIB_DIR=${D}${libdir}
- oe_runmake install
+ cd ${S}/WebKitBuilds/Debug
+ PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro \
+ WEBKIT_INC_DIR=${D}${prefix}/include WEBKIT_LIB_DIR=${D}${libdir}
+ oe_runmake install
}
-
do_stage() {
- install -d ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}
- cd ${S}/WebKitBuilds/Debug
- PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro WEBKIT_INC_DIR=${STAGING_INCDIR} WEBKIT_LIB_DIR=${STAGING_LIBDIR}
- oe_runmake install
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}
+ cd ${S}/WebKitBuilds/Debug
+ PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro \
+ WEBKIT_INC_DIR=${STAGING_INCDIR} WEBKIT_LIB_DIR=${STAGING_LIBDIR}
+ oe_runmake install
}
PACKAGES =+ "webkit-gdklauncher-dbg webkit-gdklauncher"
FILES_webkit-gdklauncher = "${bindir}/GdkLauncher"
FILES_webkit-gdklauncher-dbg = "${bindir}/.debug/GdkLauncher"
-
-
-