aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wlan-ng/files
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-14 09:02:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-14 09:02:27 +0000
commitd4b352bfeb515fb07f1b44c0332627de1d4fdeb0 (patch)
tree0289a6b70ef7f43c702d6fe5e448529b00a774f9 /packages/wlan-ng/files
parent341aeb300f4a29422eb989b04150a0c7c794a03a (diff)
downloadopenembedded-d4b352bfeb515fb07f1b44c0332627de1d4fdeb0.tar.gz
wlan-ng: move two patches that are used by more than one .bb to the files directory
Diffstat (limited to 'packages/wlan-ng/files')
-rw-r--r--packages/wlan-ng/files/pcmciasrc.patch45
-rw-r--r--packages/wlan-ng/files/scripts-makefile-hostcc.patch16
2 files changed, 61 insertions, 0 deletions
diff --git a/packages/wlan-ng/files/pcmciasrc.patch b/packages/wlan-ng/files/pcmciasrc.patch
new file mode 100644
index 0000000000..ea76baa98b
--- /dev/null
+++ b/packages/wlan-ng/files/pcmciasrc.patch
@@ -0,0 +1,45 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-wlan-ng-0.2.2/Configure~pcmciasrc
++++ linux-wlan-ng-0.2.2/Configure
+@@ -358,37 +358,6 @@
+ # kernel PCMCIA.
+
+ if [ $WLAN_KERN_PCMCIA != "y" ] ; then
+- if [ ! "$PCMCIA_SRC" ] ; then
+- if [ -f /sbin/cardctl ] ; then
+- PCMCIA_SRC=`/sbin/cardctl -V 2>&1 | sed -e 's/cardctl version //'`
+- PCMCIA_SRC=/usr/src/pcmcia-cs-$PCMCIA_SRC
+- fi
+- fi
+- ask_str "pcmcia-cs source dir" PCMCIA_SRC
+-
+- if [ ! -f $PCMCIA_SRC/Makefile ] ; then
+- $ECHO "pcmcia-cs source tree $PCMCIA_SRC is incomplete or missing!"
+- $ECHO "The wlan driver for pcmcia cannot be built without "
+- $ECHO "the pcmcia-cs source tree present and configured."
+- fail
+- fi
+- if [ ! -f $PCMCIA_SRC/include/pcmcia/config.h ] ; then
+- $ECHO "The pcmcia-cs source tree does not appear to be configured."
+- $ECHO "The wlan driver for pcmcia cannot be built without "\
+- $ECHO "the pcmcia-cs source tree present and configured."
+- fail
+- fi
+- $ECHO ""
+-
+- # Now we need to generate the module options flags.
+- # It's only relevant if modversions is turned on.
+- grep CONFIG_MODVERSIONS=y < $PCMCIA_SRC/config.mk > /dev/null
+- if [ $? = 0 ] ; then
+- PCMCIA_MODFLAGS="-DMODULE -DMODVERSIONS -include $PCMCIA_SRC/include/linux/modversions.h"
+- else
+- PCMCIA_MODFLAGS="-DMODULE"
+- fi
+-
+ # new versions of pcmcia-cs don't generate their own modversion.h
+ # if they don't have it, use the kernel module flags instead.
+ if [ ! -f $PCMCIA_SRC/include/linux/modversions.h ] ; then
diff --git a/packages/wlan-ng/files/scripts-makefile-hostcc.patch b/packages/wlan-ng/files/scripts-makefile-hostcc.patch
new file mode 100644
index 0000000000..1746b8a359
--- /dev/null
+++ b/packages/wlan-ng/files/scripts-makefile-hostcc.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-wlan-ng-0.2.2/scripts/Makefile~scripts-makefile-hostcc
++++ linux-wlan-ng-0.2.2/scripts/Makefile
+@@ -24,7 +24,7 @@
+ exit 1;\
+ fi
+
+- $(CC) -I$(KERNEL_SOURCE)/include get_version.c -o get_version
++ $(BUILD_CC) -I$(KERNEL_SOURCE)/include get_version.c -o get_version
+
+ get_options:
+ $(MAKE) -f $(CURR_DIR)/Makefile.get_options -C $(KERNEL_SOURCE) get_version_target