aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wlan-ng
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
commit1bb521fd96e47c6437bda16cf922d897a171fc14 (patch)
tree6579b2df48f9bf5f48192b377dd81d1a41c9f85b /packages/wlan-ng
parent52da54beb1ebd89a0fcfdfea8247b357128e8e97 (diff)
downloadopenembedded-1bb521fd96e47c6437bda16cf922d897a171fc14.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/20 04:02:25-05:00 handhelds.org!kergoth automake 1.9.x build fixes: ice, libsm, libxcursor, libxfixes, libxft, libxss, xcomposite, xdamage, xpm, xt, xtst. 2005/01/20 04:00:34-05:00 handhelds.org!kergoth Disable PARALLEL_MAKE in opie-tinykate. 2005/01/20 03:58:05-05:00 handhelds.org!kergoth rosetta: inherit gettext and depend on virtual/libintl. 2005/01/20 03:57:40-05:00 handhelds.org!kergoth A few STAGING_KERNEL_DIR and PACKAGE_ARCH fixes for multimachine builds. 2005/01/20 03:53:46-05:00 handhelds.org!kergoth tosa.conf: don't bother installing the real modutils.. the busybox modutils is fine. 2005/01/20 03:52:08-05:00 handhelds.org!kergoth wireless-tools: Apply patch to stop poking into the kernel headers where it shouldnt be, clean things up, use the local wireless.h instead of the kernel's, and split out into more granular ipks. 2005/01/20 03:49:43-05:00 handhelds.org!kergoth Patch ipkg to fix a bug when built for relatively recent uclibc. BKrev: 41ef8a88apPGTS6jqkoO28j6FLNtjg
Diffstat (limited to 'packages/wlan-ng')
-rw-r--r--packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb b/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb
index e69de29bb2..3a9195f412 100644
--- a/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb
+++ b/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb
@@ -0,0 +1,78 @@
+DESCRIPTION = "linux-wlan-ng (prism2.x, prism3, pcmcia, pci, usb) driver for 11Mbps wireless lan cards"
+HOMEPAGE = "http://www.linux-wlan.org"
+SECTION = "kernel/modules"
+DEPENDS = "virtual/kernel"
+RRECOMMENDS = "wlan-ng-utils"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/linux-wlan-ng-${PV}.tar.bz2 \
+ file://no-compat.patch;patch=1 \
+ file://Ambit_usb.patch;patch=1 \
+ file://scripts-makefile-hostcc.diff;patch=1;pnum=0 \
+ file://pass-kernel-cross.patch;patch=1;pnum=0 \
+ file://OZ-Configure.patch;patch=1 \
+ file://wlan-ng.modutils \
+ file://wlan.agent \
+ file://config.in \
+ file://usbctl \
+ file://resume \
+ file://pre-up \
+ file://post-down"
+S = "${WORKDIR}/linux-wlan-ng-${PV}"
+
+inherit module
+
+MAKE_TARGETS = "all"
+
+do_configure() {
+ cp ${WORKDIR}/config.in ${S}
+ if grep CONFIG_PCMCIA=[ym] ${STAGING_KERNEL_DIR}/kernel-config; then
+ export PRISM2_PCMCIA=y
+ export WLAN_KERN_PCMCIA=y
+ fi
+ export PRISM2_PCI=y
+ export PRISM2_PLX=n
+ export PRISM2_USB=y
+ export TARGET_ROOT_ON_HOST=${D}
+ export RC_DIR=${sysconfdir}
+ oe_runmake LINUX_SRC=${KERNEL_SOURCE} auto_config
+}
+
+# override module_do_install in module.oeclass - dont want to set CC and
+# LD unless actually compiling the kernel modules - there are other user
+# level programs to be compiled. Note we need to use same compiler
+# that was used to build the kernel
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
+ KERNEL_SRC=${STAGING_KERNEL_DIR} \
+ KERNEL_VERSION=${KERNEL_VERSION} \
+ KERNEL_CC="${KERNEL_CC}" KERNEL_LD="${KERNEL_LD}" \
+ ${MAKE_TARGETS}
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} TARGET_MODDIR=
+ mkdir -p ${D}/etc/modutils/
+ mkdir -p ${D}/etc/hotplug/
+ mkdir -p ${D}/sbin/
+ install -m 0644 ${WORKDIR}/wlan-ng.modutils ${D}/etc/modutils/wlan-ng.conf
+ install -m 0755 ${WORKDIR}/wlan.agent ${D}/etc/hotplug/wlan.agent
+ install -d ${D}/${sysconfdir}/network/if-pre-up.d
+ install -m 0755 ${WORKDIR}/pre-up ${D}/${sysconfdir}/network/if-pre-up.d/wlan-ng
+ install -d ${D}/${sysconfdir}/network/if-post-down.d
+ install -m 0755 ${WORKDIR}/post-down ${D}/${sysconfdir}/network/if-post-down.d/wlan-ng
+ install -d ${D}/${sysconfdir}/apm/resume.d
+ install -m 0755 ${WORKDIR}/resume ${D}/${sysconfdir}/apm/resume.d/wlan-ng
+ install -m 0755 ${WORKDIR}/usbctl ${D}/sbin/usbctl
+ install -d ${D}/${mandir}
+ mv ${D}/usr/local/man/* ${D}/${mandir}
+ rm -r ${D}/usr/local/man
+ rm -rf ${D}/etc/init.d
+}
+
+PACKAGES_prepend = "wlan-ng-utils "
+FILES_wlan-ng-utils = "${sysconfdir} /sbin"
+FILES_${PN} = "/lib"