aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wlan-ng
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/wlan-ng
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/wlan-ng')
-rw-r--r--packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb b/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb
index 3a9195f412..3ec6ff2d0d 100644
--- a/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb
+++ b/packages/wlan-ng/wlan-ng-modules_0.2.1pre23.bb
@@ -55,22 +55,22 @@ do_compile() {
do_install() {
oe_runmake install DESTDIR=${D} TARGET_MODDIR=
- mkdir -p ${D}/etc/modutils/
- mkdir -p ${D}/etc/hotplug/
- mkdir -p ${D}/sbin/
- install -m 0644 ${WORKDIR}/wlan-ng.modutils ${D}/etc/modutils/wlan-ng.conf
- install -m 0755 ${WORKDIR}/wlan.agent ${D}/etc/hotplug/wlan.agent
+ mkdir -p ${D}/${sysconfdir}/modutils/
+ mkdir -p ${D}/${sysconfdir}/hotplug/
+ mkdir -p ${D}/${base_sbindir}/
+ install -m 0644 ${WORKDIR}/wlan-ng.modutils ${D}/${sysconfdir}/modutils/wlan-ng.conf
+ install -m 0755 ${WORKDIR}/wlan.agent ${D}/${sysconfdir}/hotplug/wlan.agent
install -d ${D}/${sysconfdir}/network/if-pre-up.d
install -m 0755 ${WORKDIR}/pre-up ${D}/${sysconfdir}/network/if-pre-up.d/wlan-ng
install -d ${D}/${sysconfdir}/network/if-post-down.d
install -m 0755 ${WORKDIR}/post-down ${D}/${sysconfdir}/network/if-post-down.d/wlan-ng
install -d ${D}/${sysconfdir}/apm/resume.d
install -m 0755 ${WORKDIR}/resume ${D}/${sysconfdir}/apm/resume.d/wlan-ng
- install -m 0755 ${WORKDIR}/usbctl ${D}/sbin/usbctl
+ install -m 0755 ${WORKDIR}/usbctl ${D}/${base_sbindir}/usbctl
install -d ${D}/${mandir}
mv ${D}/usr/local/man/* ${D}/${mandir}
rm -r ${D}/usr/local/man
- rm -rf ${D}/etc/init.d
+ rm -rf ${D}/${sysconfdir}/init.d
}
PACKAGES_prepend = "wlan-ng-utils "