aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wpa-supplicant
diff options
context:
space:
mode:
authorHolger Schurig <schurig@mn-solutions.de>2005-03-10 12:38:50 +0000
committerHolger Schurig <schurig@mn-solutions.de>2005-03-10 12:38:50 +0000
commit78a271cec18b56e85326b7e70a9aeceeda7a5fbe (patch)
tree94ac261f71bfad2ccfb09c7a1188b0b88e9184f6 /packages/wpa-supplicant
parentaedef5ad29cbb4809e35a2d67630b654ff54483d (diff)
downloadopenembedded-78a271cec18b56e85326b7e70a9aeceeda7a5fbe.tar.gz
added initscript
added default config moved sample config into -doc package added ${DATE} to package version split out wpa_passphrase and wpa_cli into separate packages BKrev: 42303fda6GAk8FseeVw-87ni-piweQ
Diffstat (limited to 'packages/wpa-supplicant')
-rw-r--r--packages/wpa-supplicant/files/init.sh0
-rw-r--r--packages/wpa-supplicant/files/ramses/defaults0
-rw-r--r--packages/wpa-supplicant/wpa-supplicant_cvs.bb30
3 files changed, 26 insertions, 4 deletions
diff --git a/packages/wpa-supplicant/files/init.sh b/packages/wpa-supplicant/files/init.sh
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wpa-supplicant/files/init.sh
diff --git a/packages/wpa-supplicant/files/ramses/defaults b/packages/wpa-supplicant/files/ramses/defaults
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wpa-supplicant/files/ramses/defaults
diff --git a/packages/wpa-supplicant/wpa-supplicant_cvs.bb b/packages/wpa-supplicant/wpa-supplicant_cvs.bb
index 7e80f3e448..baa423a684 100644
--- a/packages/wpa-supplicant/wpa-supplicant_cvs.bb
+++ b/packages/wpa-supplicant/wpa-supplicant_cvs.bb
@@ -4,34 +4,56 @@ LICENSE = "GPL"
MAINTAINER = "Holger Schurig"
HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
DEPENDS = "openssl"
+PV = "0.0cvs${CVSDATE}"
PR = "r1"
SRC_URI = "cvs://anonymous@hostap.epitest.fi/cvs;module=hostap \
file://use-channel.patch;patch=1 \
file://driver-hermes.patch;patch=1 \
file://defconfig \
+ file://defaults \
+ file://init.sh \
file://wpa_supplicant.conf"
S = "${WORKDIR}/hostap/wpa_supplicant"
+
+PACKAGES_prepend = "wpa-supplicant-passphrase wpa-supplicant-cli "
+FILES_wpa-supplicant-passphrase = "/usr/sbin/wpa_passphrase"
+FILES_wpa-supplicant-cli = "/usr/sbin/wpa_cli"
+
+RRECOMMENDS_${PN} = "wpa-supplicant-passphrase wpa-supplicant-cli"
+
+
+INITSCRIPT_NAME = "wpa"
+INITSCRIPT_PARAMS = "defaults 10"
+inherit update-rc.d
+
+
do_configure () {
install -m 0755 ${WORKDIR}/defconfig .config
}
+
do_compile () {
make
}
+
do_install () {
+ set -x
install -d ${D}${sbindir}
install -m755 wpa_supplicant ${D}${sbindir}
install -m755 wpa_passphrase ${D}${sbindir}
install -m755 wpa_cli ${D}${sbindir}
- install -d ${D}${sysconfdir}
- install -m644 ${WORKDIR}/wpa_supplicant.conf ${D}${sysconfdir}
+ install -d ${D}${localstatedir}/run/wpa_supplicant
install -d ${D}${docdir}/wpa_supplicant
- install -m644 README ${D}${docdir}/wpa_supplicant
-}
+ install -m644 README ${WORKDIR}/wpa_supplicant.conf ${D}${docdir}/wpa_supplicant
+ install -d ${D}${sysconfdir}/init.d
+ install -m700 ${WORKDIR}/init.sh ${D}${sysconfdir}/init.d/wpa
+ install -d ${D}${sysconfdir}/defaults
+ install -m600 ${WORKDIR}/defaults ${D}${sysconfdir}/defaults/wpa
+}