aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wpa-supplicant
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2005-01-27 20:35:52 +0000
committerPhil Blundell <philb@gnu.org>2005-01-27 20:35:52 +0000
commit7de97518c25bd061f09f875a71985dbf46da99b3 (patch)
tree3b21879ca13e7ef9e22d3f0e284401b89af3bac4 /packages/wpa-supplicant
parent6ccdaf8b930d54e863f55e6f61b542be73046618 (diff)
downloadopenembedded-7de97518c25bd061f09f875a71985dbf46da99b3.tar.gz
add RREPLACES/RPROVIDES/RCONFLICTS for old hostap-* supplicant packages
BKrev: 41f950a8w-hk9KXM04y3wzIz7SqaWA
Diffstat (limited to 'packages/wpa-supplicant')
-rw-r--r--packages/wpa-supplicant/wpa-supplicant-nossl_0.2.6.bb7
-rw-r--r--packages/wpa-supplicant/wpa-supplicant-ssl_0.2.6.bb2
-rw-r--r--packages/wpa-supplicant/wpa-supplicant_0.2.6.inc34
3 files changed, 42 insertions, 1 deletions
diff --git a/packages/wpa-supplicant/wpa-supplicant-nossl_0.2.6.bb b/packages/wpa-supplicant/wpa-supplicant-nossl_0.2.6.bb
index e69de29bb2..2e9e1b879f 100644
--- a/packages/wpa-supplicant/wpa-supplicant-nossl_0.2.6.bb
+++ b/packages/wpa-supplicant/wpa-supplicant-nossl_0.2.6.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "User space helper for WPA and WPA2 client operations. \
+The Supplicant is used in WPA/WPA2 key handshakes to authenticate \
+with the AP and to generate dynamic encryption keys (TKIP or CCMP)."
+
+PR = "r3"
+
+include wpa-supplicant_${PV}.inc
diff --git a/packages/wpa-supplicant/wpa-supplicant-ssl_0.2.6.bb b/packages/wpa-supplicant/wpa-supplicant-ssl_0.2.6.bb
index 7c7321b7de..85cdbb3379 100644
--- a/packages/wpa-supplicant/wpa-supplicant-ssl_0.2.6.bb
+++ b/packages/wpa-supplicant/wpa-supplicant-ssl_0.2.6.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "User space helper for WPA and WPA2 client operations with SSL. \
The Supplicant is used in WPA/WPA2 key handshakes to authenticate \
with the AP and to generate dynamic encryption keys (TKIP or CCMP)."
DEPENDSS = "openssl"
-PR = "r2"
+PR = "r3"
EXTRA_OEMAKE="LIBS='-L${STAGING_LIBDIR} -lssl -lcrypto' LIBS_p='-L${STAGING_LIBDIR} -lssl -lcrypto'"
diff --git a/packages/wpa-supplicant/wpa-supplicant_0.2.6.inc b/packages/wpa-supplicant/wpa-supplicant_0.2.6.inc
index e69de29bb2..c1a6876b68 100644
--- a/packages/wpa-supplicant/wpa-supplicant_0.2.6.inc
+++ b/packages/wpa-supplicant/wpa-supplicant_0.2.6.inc
@@ -0,0 +1,34 @@
+SECTION = "kernel/userland"
+HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+
+SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \
+ file://wpa-defconfig \
+ file://wpa_supplicant_default.conf"
+
+RREPLACES_${PN} = "hostap-${PN}"
+RPROVIDES_${PN} = "hostap-${PN}"
+RCONFLICTS_${PN} = "hostap-${PN}"
+
+S = "${WORKDIR}/wpa_supplicant-${PV}"
+
+do_compile() {
+ unset CFLAGS
+ base_do_compile
+}
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/wpa-defconfig .config
+}
+
+do_install() {
+ install -d ${D}/${sysconfdir} ${D}/${bindir}
+ install -m 0644 wpa_supplicant.conf ${D}/${sysconfdir}/wpa_supplicant.conf.sample
+ install -m 0644 ../wpa_supplicant_default.conf ${D}/${sysconfdir}/wpa_supplicant.conf
+ install -m 0755 wpa_passphrase ${D}/${bindir}
+ install -m 0755 wpa_cli ${D}/${bindir}
+ install -m 0755 wpa_supplicant ${D}/${bindir}
+}
+