aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wvstreams
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-04-12 15:02:56 +0000
committerHolger Freyther <ich@tamarin.(none)>2008-10-15 18:53:42 +0200
commit9956063810146b519b97df71ef0fdcda2fe81a98 (patch)
treea034a4dc1159459115cdc630df84a56ccebe196c /packages/wvstreams
parent7854e5fe6276fe2c2c57b329b1940423cda82ad3 (diff)
downloadopenembedded-9956063810146b519b97df71ef0fdcda2fe81a98.tar.gz
wvstreams: Add initial compiling and linking version. This is needed for wvdial
- Cure some symptoms of the broken buildsystem
Diffstat (limited to 'packages/wvstreams')
-rw-r--r--packages/wvstreams/files/build-fixes-and-sanity.patch84
-rw-r--r--packages/wvstreams/wvstreams_4.4.1.bb16
2 files changed, 100 insertions, 0 deletions
diff --git a/packages/wvstreams/files/build-fixes-and-sanity.patch b/packages/wvstreams/files/build-fixes-and-sanity.patch
new file mode 100644
index 0000000000..1571d7b3fe
--- /dev/null
+++ b/packages/wvstreams/files/build-fixes-and-sanity.patch
@@ -0,0 +1,84 @@
+Index: wvstreams-4.4.1/configure.ac
+===================================================================
+--- wvstreams-4.4.1.orig/configure.ac 2007-08-30 04:47:54.000000000 +0200
++++ wvstreams-4.4.1/configure.ac 2008-04-12 00:15:13.000000000 +0200
+@@ -445,7 +445,6 @@
+ # tcl
+ if test "$with_tcl" != "no"; then
+ CPPFLAGS_save="$CPPFLAGS"
+- WV_APPEND(CPPFLAGS, -I/usr/include/tcl8.3)
+ AC_CHECK_HEADERS(tcl.h,, [with_tcl=no])
+ AC_CHECK_LIB(tcl8.3, TclInterpInit,, [with_tcl=no])
+ if test "$with_tcl" != "no"; then
+Index: wvstreams-4.4.1/Makefile
+===================================================================
+--- wvstreams-4.4.1.orig/Makefile 2007-08-30 04:48:09.000000000 +0200
++++ wvstreams-4.4.1/Makefile 2008-04-12 00:51:51.000000000 +0200
+@@ -76,7 +76,7 @@
+ $(call configure)
+
+ include/wvautoconf.h: include/wvautoconf.h.in
+- $(call configure)
++
+
+ gnulib/Makefile: gnulib/Makefile.in
+ $(call configure)
+@@ -97,9 +97,7 @@
+ @touch $@
+
+ configure: configure.ac include/wvautoconf.h.in aclocal.m4
+- autoconf
+- @rm -f config.mk include/wvautoconf.h gnulib/Makefile
+- @touch $@
++ @echo hey@
+
+ include/wvautoconf.h.in: configure.ac aclocal.m4
+ autoheader
+Index: wvstreams-4.4.1/config.mk.in
+===================================================================
+--- wvstreams-4.4.1.orig/config.mk.in 2007-08-17 07:15:31.000000000 +0200
++++ wvstreams-4.4.1/config.mk.in 2008-04-12 00:25:54.000000000 +0200
+@@ -31,6 +31,7 @@
+
+ prefix=@prefix@
+ datadir=@datadir@
++datarootdir=@datarootdir@
+ includedir=@includedir@
+ infodir=@infodir@
+ localstatedir=@localstatedir@
+Index: wvstreams-4.4.1/vars.mk
+===================================================================
+--- wvstreams-4.4.1.orig/vars.mk 2007-08-17 07:15:31.000000000 +0200
++++ wvstreams-4.4.1/vars.mk 2008-04-12 01:44:03.000000000 +0200
+@@ -174,7 +174,7 @@
+
+ libwvutils.a libwvutils.so: $(filter-out $(BASEOBJS) $(TESTOBJS),$(call objects,utils)) gnulib/libgnu.a
+ libwvutils.so: libwvbase.so
+-libwvutils.so: -lz -lcrypt
++libwvutils.so: LIBS+=-lz -lcrypt
+
+ libwvstreams.a libwvstreams.so: $(filter-out $(BASEOBJS), \
+ $(call objects,configfile crypto ipstreams \
+Index: wvstreams-4.4.1/wvrules.mk
+===================================================================
+--- wvstreams-4.4.1.orig/wvrules.mk 2007-08-17 07:15:31.000000000 +0200
++++ wvstreams-4.4.1/wvrules.mk 2008-04-12 01:00:05.000000000 +0200
+@@ -51,7 +51,7 @@
+ LIBWVTEST=$(WVSTREAMS_LIB)/libwvtest.a $(LIBWVUTILS)
+
+ # Default compiler we use for linking
+-WVLINK_CC = gcc
++WVLINK_CC = $(CC)
+
+ # FIXME: what does this do??
+ XX_LIBS := $(XX_LIBS) $(shell $(CC) -lsupc++ -lgcc_eh 2>&1 | grep -q "undefined reference" && echo " -lsupc++ -lgcc_eh")
+Index: wvstreams-4.4.1/xplc/config/config.mk.in
+===================================================================
+--- wvstreams-4.4.1.orig/xplc/config/config.mk.in 2005-10-31 23:33:26.000000000 +0100
++++ wvstreams-4.4.1/xplc/config/config.mk.in 2008-04-12 00:27:33.000000000 +0200
+@@ -49,4 +49,4 @@
+ LN_S:=@LN_S@
+ LIBS:=@LIBS@
+ CVS2CL:=@CVS2CL@
+-
++datarootdir:=@datarootdir@
diff --git a/packages/wvstreams/wvstreams_4.4.1.bb b/packages/wvstreams/wvstreams_4.4.1.bb
new file mode 100644
index 0000000000..5a20840861
--- /dev/null
+++ b/packages/wvstreams/wvstreams_4.4.1.bb
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
+LICENSE = "LGPL"
+DESCRIPTION = "WvStreams is a network programming library in C++"
+DEPENDS = "zlib openssl (>= 0.9.8)"
+
+SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://build-fixes-and-sanity.patch;patch=1 "
+
+inherit autotools
+
+LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
+
+EXTRA_AUTORECONF += " -I${S}/gnulib/m4"
+EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
+
+