aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wwwoffle
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2008-05-18 21:01:06 +0000
committerStanislav Brabec <utx@penguin.cz>2008-05-18 21:01:06 +0000
commit522855b0497d48717f15d4d3ad3b7efa0d99b5fe (patch)
treec3d1a8b4775b8807c583d617ffb949979d3643e4 /packages/wwwoffle
parent97758eab3cc90d70ab04d5b4f35bc0023bee3044 (diff)
downloadopenembedded-522855b0497d48717f15d4d3ad3b7efa0d99b5fe.tar.gz
New package wwwoffle: World Wide Web Offline Explorer (offline http+ftp proxy)
Diffstat (limited to 'packages/wwwoffle')
-rw-r--r--packages/wwwoffle/.mtn2git_empty0
-rw-r--r--packages/wwwoffle/files/.mtn2git_empty0
-rw-r--r--packages/wwwoffle/files/wwwoffle.if-down4
-rw-r--r--packages/wwwoffle/files/wwwoffle.if-up36
-rw-r--r--packages/wwwoffle/files/wwwoffle.init22
-rw-r--r--packages/wwwoffle/wwwoffle_2.9c.bb31
6 files changed, 93 insertions, 0 deletions
diff --git a/packages/wwwoffle/.mtn2git_empty b/packages/wwwoffle/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wwwoffle/.mtn2git_empty
diff --git a/packages/wwwoffle/files/.mtn2git_empty b/packages/wwwoffle/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wwwoffle/files/.mtn2git_empty
diff --git a/packages/wwwoffle/files/wwwoffle.if-down b/packages/wwwoffle/files/wwwoffle.if-down
new file mode 100644
index 0000000000..71721c38d5
--- /dev/null
+++ b/packages/wwwoffle/files/wwwoffle.if-down
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+/usr/bin/wwwoffle -offline &
+exit
diff --git a/packages/wwwoffle/files/wwwoffle.if-up b/packages/wwwoffle/files/wwwoffle.if-up
new file mode 100644
index 0000000000..43167a9e9c
--- /dev/null
+++ b/packages/wwwoffle/files/wwwoffle.if-up
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+# We want to run wwwoffle only for selected interfaces:
+# Maybe better would be checking of the default route.
+case "$IFACE" in
+ wlan*)
+ ;;
+ eth*)
+ ;;
+ usb*)
+ ;;
+ ppp*)
+ ;;
+ *)
+ exit 0
+ ;;
+esac
+
+# wwwoffle caches old network configuration and it may cause resolve failures
+/usr/bin/wwwoffle -kill
+/usr/sbin/wwwoffled >/dev/null 2>&1
+
+/usr/bin/wwwoffle -online
+
+# Don't fetch over ppp*, which is typically expensive dial-up.
+# Comment out, if you want to fetch pre-ordered pages over GPRS, dial-up or so.
+case "$IFACE" in
+ ppp*)
+ exit 0
+ ;;
+esac
+
+# Fetch may take longer time. Run it in background
+( /usr/bin/wwwoffle -fetch ) &
+
+exit
diff --git a/packages/wwwoffle/files/wwwoffle.init b/packages/wwwoffle/files/wwwoffle.init
new file mode 100644
index 0000000000..7eac239a3e
--- /dev/null
+++ b/packages/wwwoffle/files/wwwoffle.init
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ /usr/sbin/wwwoffled
+ ;;
+restart)
+ /usr/bin/wwwoffle -kill
+ /usr/sbin/wwwoffled >/dev/null 2>&1
+ ;;
+reload|force-reload)
+ /usr/bin/wwwoffle -config
+ ;;
+stop)
+ /usr/bin/wwwoffle -kill
+ ;;
+*)
+ echo "Usage: /etc/init.d/wwwoffle {start|stop|restart|reload|force-reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/packages/wwwoffle/wwwoffle_2.9c.bb b/packages/wwwoffle/wwwoffle_2.9c.bb
new file mode 100644
index 0000000000..c280e7c8a9
--- /dev/null
+++ b/packages/wwwoffle/wwwoffle_2.9c.bb
@@ -0,0 +1,31 @@
+LICENSE = "GPL"
+SECTION = "console/network"
+PRIORITY = "standard"
+DESCRIPTION = "World Wide Web Offline Explorer"
+DEPENDS = ""
+
+SRC_URI = "http://www.gedanken.demon.co.uk/download-wwwoffle/${PN}-${PV}.tgz \
+ file://wwwoffle.init \
+ file://wwwoffle.if-up \
+ file://wwwoffle.if-down"
+
+INITSCRIPT_NAME = "${PN}"
+
+inherit autotools gettext update-rc.d
+
+EXTRA_OEMAKE = "docdir=${datadir}/doc"
+
+do_configure() {
+ pwd
+ mv aclocal.m4 acinclude.m4
+ autotools_do_configure
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/network/if-up.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-up ${D}/${sysconfdir}/network/if-up.d/wwwoffle
+ install -d ${D}/${sysconfdir}/network/if-down.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-down ${D}/${sysconfdir}/network/if-down.d/wwwoffle
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/wwwoffle.init ${D}/${sysconfdir}/init.d/wwwoffle
+}