aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xorg-lib/libx11
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-07-24 19:46:41 +0000
committerRaymond Danks <raymond@edanks.com>2006-07-24 19:46:41 +0000
commitdd0c887b669ed5f2fdfa21118f4b32d096e92816 (patch)
tree52a9bb766480ea9983a6e3e5d4ae600e0a482f2c /packages/xorg-lib/libx11
parentb88c8ee5fdd3c5bda8a7fea778c3d7b09b180622 (diff)
downloadopenembedded-dd0c887b669ed5f2fdfa21118f4b32d096e92816.tar.gz
xorg-*: Massive rename to conform to X11R7.x_a.b.c versioning and xorg-* directory structure.
This is the first step for the update to X11R7.1. This will not build and will be followed by more patches and updates.
Diffstat (limited to 'packages/xorg-lib/libx11')
-rw-r--r--packages/xorg-lib/libx11/.mtn2git_empty0
-rw-r--r--packages/xorg-lib/libx11/autofoo.patch22
-rw-r--r--packages/xorg-lib/libx11/xim.patch55
3 files changed, 77 insertions, 0 deletions
diff --git a/packages/xorg-lib/libx11/.mtn2git_empty b/packages/xorg-lib/libx11/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xorg-lib/libx11/.mtn2git_empty
diff --git a/packages/xorg-lib/libx11/autofoo.patch b/packages/xorg-lib/libx11/autofoo.patch
new file mode 100644
index 0000000000..8bdba09768
--- /dev/null
+++ b/packages/xorg-lib/libx11/autofoo.patch
@@ -0,0 +1,22 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- libX11-6.2.1/configure.ac~autofoo
++++ libX11-6.2.1/configure.ac
+@@ -7,12 +7,12 @@
+ [jg@freedesktop.org],
+ libX11)
+ AC_CONFIG_SRCDIR([Makefile.am])
+-AM_INIT_AUTOMAKE([dist-bzip2])
++AC_CONFIG_AUX_DIR(.)
+
++AM_INIT_AUTOMAKE([dist-bzip2])
+ AM_MAINTAINER_MODE
+
+ AM_CONFIG_HEADER([src/config.h])
+-AC_CONFIG_AUX_DIR(.)
+
+ # Checks for programs.
+ AC_PROG_LIBTOOL
diff --git a/packages/xorg-lib/libx11/xim.patch b/packages/xorg-lib/libx11/xim.patch
new file mode 100644
index 0000000000..0eab197a80
--- /dev/null
+++ b/packages/xorg-lib/libx11/xim.patch
@@ -0,0 +1,55 @@
+--- libX11-6.2.1/src/X18NCMSstubs.c 2003-12-04 22:47:47.000000000 +0000
++++ libX11-6.2.1/src/X18NCMSstubs.c-new 2005-12-09 12:09:03.000000000 +0000
+@@ -90,6 +90,52 @@
+ return;
+ }
+
++XIM
++XOpenIM (
++ Display* display,
++ struct _XrmHashBucketRec* rdb,
++ char* res_name,
++ char* res_class)
++{
++ return (XIM) NULL;
++}
++
++Status
++XCloseIM ( XIM im )
++{
++ return NULL;
++}
++
++XIC
++XCreateIC ( XIM im, ...)
++{
++ return NULL;
++}
++
++void
++XDestroyIC ( XIC ic )
++{
++ return;
++}
++
++int
++XmbLookupString (
++ XIC ic,
++ XKeyPressedEvent* ev,
++ char* buffer,
++ int nbytes,
++ KeySym* keysym,
++ Status* status)
++{
++ return XLookupNone;
++}
++
++char *
++XGetICValues( XIC ic, ...)
++{
++ return (char *) NULL;
++}
++
+ XPointer
+ _XimGetLocaleCode ( _Xconst char* encoding_name )
+ {