aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xorg-xserver
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-02-27 09:12:18 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-02-27 09:12:18 +0000
commitd04093e34aee0effce762a26db0f4c29a7c9c4f1 (patch)
tree4b740f59988bb8704556ad72658c48cdf65bb621 /packages/xorg-xserver
parentd1998c1536b649e9a787f3f1970974a27a2d2713 (diff)
downloadopenembedded-d04093e34aee0effce762a26db0f4c29a7c9c4f1.tar.gz
xserver-kdrive-glamo_1.3.0.0+git.bb : an Xglamo recipe on its own pulling
from the developers git tree directly.
Diffstat (limited to 'packages/xorg-xserver')
-rw-r--r--packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb b/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
new file mode 100644
index 0000000000..9f38760234
--- /dev/null
+++ b/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "X server for glamo chip in GTA02"
+SECTION = "x11/base"
+LICENSE = "MIT"
+DEPENDS = "compositeproto damageproto fixesproto recordproto resourceproto \
+ scrnsaverproto xineramaproto videoproto xextproto xproto \
+ libxau libxext libxdmcp libxfont libxrandr tslib virtual/libx11 \
+ xtrans libxkbfile libxcalibrate"
+DEPENDS += "libxkbfile libxcalibrate"
+RDEPENDS_${PN} = "xserver-kdrive"
+PROVIDES = "virtual/xserver"
+PE = "1"
+PR = "r0"
+
+XGLAMO_GIT_REV = "d96175a2db993ef4bc7d9d910e0b47ec7ff20561"
+
+SRC_URI = "git://people.freedesktop.org/~dodji/xglamo;protocol=git;rev=${XGLAMO_GIT_REV} \
+ file://kmode.patch;patch=1 \
+ file://disable-apm.patch;patch=1 \
+ file://no-serial-probing.patch;patch=1 \
+ file://fbdev-not-fix.patch;patch=1 \
+ file://optional-xkb.patch;patch=1 \
+ file://enable-tslib.patch;patch=1 \
+ file://kmode-palm.patch;patch=1 \
+ file://enable-epson.patch;patch=1 \
+ file://enable-builtin-fonts.patch;patch=1 \
+ file://kdrive-evdev.patch;patch=1 \
+ file://kdrive-use-evdev.patch;patch=1 \
+ file://disable-xf86-dga-xorgcfg.patch;patch=1 \
+ file://fix_default_mode.patch;patch=1 \
+ file://enable-xcalibrate.patch;patch=1 \
+ file://hide-cursor-and-ppm-root.patch;patch=1 \
+ file://xcalibrate_coords.patch;patch=1 \
+ file://w100.patch;patch=1 \
+ file://w100-autofoo.patch;patch=1 \
+ file://w100-fix-offscreen-bmp.patch;patch=1 \
+ file://kdrive-1.3-18bpp.patch;patch=1 \
+ file://gumstix-kmode.patch;patch=1 \
+"
+
+FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-1.3.0.0:${FILE_DIRNAME}/xserver-kdrive:${FILE_DIRNAME}/files"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-composite --enable-kdrive \
+ --disable-dga --disable-dri --disable-xinerama \
+ --disable-xf86misc --disable-xf86vidmode \
+ --disable-xorg --disable-xorgcfg \
+ --disable-xkb --disable-xnest --disable-xvfb \
+ --disable-xevie --disable-xprint --disable-xtrap \
+ --disable-dmx \
+ --with-default-font-path=built-ins \
+ --enable-tslib --enable-xcalibrate \
+ ac_cv_file__usr_share_X11_sgml_defs_ent=no"
+
+do_configure_prepend() {
+ sed -i -e 's/tslib-0.0/tslib-1.0/' ${S}/configure.ac
+}
+
+FILES_${PN} = "${bindir}/Xglamo"
+FILES_${PN}-dbg = "${bindir}/.debug/Xglamo"
+
+ARM_INSTRUCTION_SET = "arm"