aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xserver-common
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-02-09 18:15:22 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-02-09 18:15:22 +0000
commitff636a015c26dd71d8a4ad5827eff6f6dabbb439 (patch)
tree165f21af93c5cd60dde6836e0c2eb9baeca390ed /packages/xserver-common
parent8afb6c6f4dbcb8c14f42d9c95cc761a8a4cee422 (diff)
downloadopenembedded-ff636a015c26dd71d8a4ad5827eff6f6dabbb439.tar.gz
xserver-common 1.13: Add patch to skip touchscreen calibration if there's no TS.
* Fixes GPE startup on TS-less machines like efika, qemu-arm, x86, lots of others.
Diffstat (limited to 'packages/xserver-common')
-rw-r--r--packages/xserver-common/files/calibrate-only-if-ts.patch9
-rw-r--r--packages/xserver-common/xserver-common_1.13.bb5
2 files changed, 12 insertions, 2 deletions
diff --git a/packages/xserver-common/files/calibrate-only-if-ts.patch b/packages/xserver-common/files/calibrate-only-if-ts.patch
new file mode 100644
index 0000000000..7be808ba04
--- /dev/null
+++ b/packages/xserver-common/files/calibrate-only-if-ts.patch
@@ -0,0 +1,9 @@
+--- a/run-calibrate.sh.org 2006-10-12 10:19:42.000000000 +0000
++++ b/run-calibrate.sh 2007-02-09 17:54:55.000000000 +0000
+@@ -1,3 +1,5 @@
+ #! /bin/sh
+
+-exec xtscal
++if [ -e /dev/input/touchscreen0 ]; then
++ exec xtscal
++fi
diff --git a/packages/xserver-common/xserver-common_1.13.bb b/packages/xserver-common/xserver-common_1.13.bb
index b051b5aea2..ebe54ecd19 100644
--- a/packages/xserver-common/xserver-common_1.13.bb
+++ b/packages/xserver-common/xserver-common_1.13.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
-PR = "r1"
+PR = "r2"
PACKAGE_ARCH = "all"
@@ -10,7 +10,8 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;patch=1"
+ file://xserver-imageon.patch;patch=1 \
+ file://calibrate-only-if-ts.patch;patch=1"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"