aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xstroke
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/xstroke
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/xstroke')
-rw-r--r--packages/xstroke/.mtn2git_empty0
-rw-r--r--packages/xstroke/xstroke-0.6/.mtn2git_empty0
-rw-r--r--packages/xstroke/xstroke-0.6/auto-disable.patch20
-rw-r--r--packages/xstroke/xstroke_0.6.bb12
4 files changed, 32 insertions, 0 deletions
diff --git a/packages/xstroke/.mtn2git_empty b/packages/xstroke/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xstroke/.mtn2git_empty
diff --git a/packages/xstroke/xstroke-0.6/.mtn2git_empty b/packages/xstroke/xstroke-0.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xstroke/xstroke-0.6/.mtn2git_empty
diff --git a/packages/xstroke/xstroke-0.6/auto-disable.patch b/packages/xstroke/xstroke-0.6/auto-disable.patch
index e69de29bb2..693460cad9 100644
--- a/packages/xstroke/xstroke-0.6/auto-disable.patch
+++ b/packages/xstroke/xstroke-0.6/auto-disable.patch
@@ -0,0 +1,20 @@
+Index: control_win.c
+===================================================================
+RCS file: /cvs/xstroke/xstroke/control_win.c,v
+retrieving revision 1.21
+diff -u -r1.21 control_win.c
+--- control_win.c 28 Sep 2003 11:53:42 -0000 1.21
++++ control_win.c 24 Jul 2004 15:02:52 -0000
+@@ -646,9 +646,11 @@
+ if (XGetWindowAttributes(dpy, window, &attr)) {
+ if (attr.all_event_masks & (KeyPressMask | KeyReleaseMask)) {
+ return 1;
++ } else if (attr.all_event_masks & PointerMotionMask) {
++ return 0;
+ }
+ }
+- return 0;
++ return 1;
+ }
+
+ /*
diff --git a/packages/xstroke/xstroke_0.6.bb b/packages/xstroke/xstroke_0.6.bb
index e69de29bb2..ebed8fd0da 100644
--- a/packages/xstroke/xstroke_0.6.bb
+++ b/packages/xstroke/xstroke_0.6.bb
@@ -0,0 +1,12 @@
+LICENSE = GPL
+SECTION = "x11"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "x11 xft xtst"
+DESCRIPTION = "Gesture recognition input method for X11"
+PR = "r1"
+
+SRC_URI = "http://xstroke.org/releases/xstroke-0.6.tar.gz \
+ file://auto-disable.patch;patch=1;pnum=0"
+
+inherit autotools pkgconfig