aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zaurusd
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2007-11-19 16:57:59 +0000
committerMatthias Hentges <oe@hentges.net>2007-11-19 16:57:59 +0000
commit154b49c75d9058b9904986cc1d0f2913a7ce6388 (patch)
tree63eeaea7e15094767683a7209e17a415b5e5786d /packages/zaurusd
parenta69b517b8cf3a3cc14658c2aeeda92b87ed17985 (diff)
downloadopenembedded-154b49c75d9058b9904986cc1d0f2913a7ce6388.tar.gz
zaurusd: Try a bit harder to re-enable the backlight on hinge-open and resume when APM fails to do so for whatever reason
Diffstat (limited to 'packages/zaurusd')
-rw-r--r--packages/zaurusd/files/zaurus-hinge.bl-on18
-rw-r--r--packages/zaurusd/zaurusd_svn.bb2
2 files changed, 19 insertions, 1 deletions
diff --git a/packages/zaurusd/files/zaurus-hinge.bl-on b/packages/zaurusd/files/zaurus-hinge.bl-on
index 6d416ad8c4..b9b0e68749 100644
--- a/packages/zaurusd/files/zaurus-hinge.bl-on
+++ b/packages/zaurusd/files/zaurus-hinge.bl-on
@@ -8,3 +8,21 @@
test -z "${ZD_BINDIR}" && ZD_BINDIR="/usr/bin"
${ZD_BINDIR}/bl on
+
+# If the backlight does not come back on after a suspend, the driver is
+# still "on" (hence "bl on" does nothing) with a brightness of "0"
+
+if test "`bl | awk '{print $2}'`" = "0"
+then
+ x=0
+ while test "$x" != 4
+ do
+ bl 10
+ usleep 10
+ bl 50
+ usleep 10
+
+ let x=$x+1
+ done
+fi
+
diff --git a/packages/zaurusd/zaurusd_svn.bb b/packages/zaurusd/zaurusd_svn.bb
index 2b918bbaa3..aa503f273a 100644
--- a/packages/zaurusd/zaurusd_svn.bb
+++ b/packages/zaurusd/zaurusd_svn.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
DEPENDS = "tslib"
RDEPENDS = "procps"
PV = "0.0+svn${SRCDATE}"
-PR = "r10"
+PR = "r11"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
file://zaurus-hinge.in \