aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zlib/zlib_1.2.3.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-08-06 19:45:08 +0000
committerHolger Freyther <zecke@selfish.org>2006-08-06 19:45:08 +0000
commit4f808eb2f1265e33852fb926fe74d04ba9d27b9a (patch)
tree4541e92b2a5b6edc360fc0ab1ac6b9fa6cc93b07 /packages/zlib/zlib_1.2.3.bb
parentccec27323e3f552fcd1af2ff90fe099be0c88401 (diff)
downloadopenembedded-4f808eb2f1265e33852fb926fe74d04ba9d27b9a.tar.gz
packaes/zlib: Do not use uname to determine the library ending
Do not use uname to decide if the library ends with dylib or so. And where to put the Version numbers... For darwin unset LDSHARED as we do not have gcc -shared to zlib should use autofoo to decide such things...
Diffstat (limited to 'packages/zlib/zlib_1.2.3.bb')
-rw-r--r--packages/zlib/zlib_1.2.3.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/packages/zlib/zlib_1.2.3.bb b/packages/zlib/zlib_1.2.3.bb
index c7a72c9107..8a48a89fdf 100644
--- a/packages/zlib/zlib_1.2.3.bb
+++ b/packages/zlib/zlib_1.2.3.bb
@@ -7,7 +7,8 @@ LICENSE = "zlib"
SRC_URI = "http://www.zlib.net/zlib-1.2.3.tar.bz2 \
file://visibility.patch;patch=1 \
- file://libtool_staging.patch;patch=1"
+ file://libtool_staging.patch;patch=1 \
+ file://sane-target.patch;patch=1 "
S = "${WORKDIR}/zlib-${PV}"
@@ -19,9 +20,13 @@ CFLAGS_prepend = "-fPIC -DZLIB_DLL "
AR_append = " rc"
EXTRA_OEMAKE = " LIBTOOL=${TARGET_SYS}-libtool"
+# extra configure options, can be reset in the -native variant
+ZLIB_EXTRA = "--target=${TARGET_OS}"
+ZLIB_SHARED= "libz.so.${PV}"
+
do_compile() {
- ./configure --prefix=${prefix} --exec_prefix=${exec_prefix} --shared --libdir=${libdir} --includedir=${includedir}
- oe_runmake -e MAKEFLAGS="" libz.so.${PV} libz.a
+ ./configure --prefix=${prefix} --exec_prefix=${exec_prefix} --shared --libdir=${libdir} --includedir=${includedir} ${ZLIB_EXTRA}
+ oe_runmake -e MAKEFLAGS="" ${ZLIB_SHARED} libz.a
}
do_stage() {