aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zope
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-06-07 08:30:52 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-06-07 08:30:52 +0000
commitc53e2a7cc1ffbd279bed3a128accc4f3375d9e50 (patch)
tree1934740ab907e7e2f9f8d5fa55eb23455e3b11ba /packages/zope
parent170ddb0497041fecdf901b604c183f3f3db785ea (diff)
downloadopenembedded-c53e2a7cc1ffbd279bed3a128accc4f3375d9e50.tar.gz
zope: added 3.3.1 from Poky
Diffstat (limited to 'packages/zope')
-rw-r--r--packages/zope/zope_3.3.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/zope/zope_3.3.1.bb b/packages/zope/zope_3.3.1.bb
new file mode 100644
index 0000000000..156de2134f
--- /dev/null
+++ b/packages/zope/zope_3.3.1.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "A full fledged pluggable content management system with integrated web server and much more."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "python"
+RDEPENDS = "python-core python-shell"
+LICENSE = "ZPL"
+PR = "r2"
+
+SRC_URI = "http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
+
+S = "${WORKDIR}/Zope-${PV}"
+
+do_configure() {
+ ./configure --with-python=${STAGING_BINDIR_NATIVE}/python --prefix=${prefix} --force
+}
+
+do_compile() {
+ oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
+}
+
+do_install() {
+ oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
+}
+
+PACKAGES =+ "python-zopeinterface python-zopeinterface-dbg"
+
+FILES_${PN} = "${prefix}"
+FILES_${PN}_doc = "${prefix}/doc"
+FILES_${PN}-dbg += "\
+${libdir}/python/BTrees/.debug \
+${libdir}/python/persistent/.debug \
+${libdir}/python/zope/proxy/.debug \
+${libdir}/python/zope/thread/.debug \
+${libdir}/python/zope/security/.debug \
+${libdir}/python/zope/hookable/.debug \
+${libdir}/python/zope/app/container/.debug \
+${libdir}/python/zope/i18nmessageid/.debug \
+${libdir}/python/ZODB/.debug"
+FILES_python-zopeinterface-dbg += "${libdir}/python/zope/interface/.debug "
+
+FILES_python-zopeinterface = "${libdir}/python/zope/interface/*.* ${libdir}/python/zope/interface/common"