aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-11-21 09:43:44 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-11-21 09:43:44 +0000
commit329d886e11994520e702e5a1e89aa14e6e3377c3 (patch)
tree00d497eaef70118875851658a4525ee141a3bf86 /packages
parente13e6a9551cac5adf8ebcf1b47b99477afcabdc4 (diff)
downloadopenembedded-329d886e11994520e702e5a1e89aa14e6e3377c3.tar.gz
libmad: Add 0.15.1b (from poky)
Diffstat (limited to 'packages')
-rw-r--r--packages/libmad/libmad_0.15.1b.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/libmad/libmad_0.15.1b.bb b/packages/libmad/libmad_0.15.1b.bb
new file mode 100644
index 0000000000..aac3736135
--- /dev/null
+++ b/packages/libmad/libmad_0.15.1b.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "MPEG Audio Decoder Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libid3tag"
+LICENSE = "GPL"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libmad-${PV}.tar.gz"
+S = "${WORKDIR}/libmad-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "-enable-speed --enable-shared"
+# The ASO's don't take any account of thumb...
+EXTRA_OECONF_append_thumb = " --disable-aso --enable-fpm=default"
+EXTRA_OECONF_append_arm = " --enable-fpm=arm"
+
+do_configure_prepend () {
+# damn picky automake...
+ touch NEWS AUTHORS ChangeLog
+}
+
+do_stage() {
+ oe_libinstall -so libmad ${STAGING_LIBDIR}
+ install -m 0644 mad.h ${STAGING_INCDIR}
+}