aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-11-21 09:45:02 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-11-21 09:45:02 +0000
commita9ffadeccc2babc56563d3b33db5d896a4d6637a (patch)
tree98756005ffb1186cbc81834e942a3efa00ff85fd /packages
parent329d886e11994520e702e5a1e89aa14e6e3377c3 (diff)
downloadopenembedded-a9ffadeccc2babc56563d3b33db5d896a4d6637a.tar.gz
coreutils: Add workaround to allow -native version to work with Ubuntu Edgy headers (from poky)
Diffstat (limited to 'packages')
-rw-r--r--packages/coreutils/coreutils-5.1.3/rename-eaccess.patch44
-rw-r--r--packages/coreutils/coreutils_5.1.3.bb5
2 files changed, 47 insertions, 2 deletions
diff --git a/packages/coreutils/coreutils-5.1.3/rename-eaccess.patch b/packages/coreutils/coreutils-5.1.3/rename-eaccess.patch
new file mode 100644
index 0000000000..cde2731477
--- /dev/null
+++ b/packages/coreutils/coreutils-5.1.3/rename-eaccess.patch
@@ -0,0 +1,44 @@
+# On Ubuntu edgy (and perhaps other distributions), eaccess is provided by
+# unistd.h - This renames the function so as not to conflict.
+
+--- coreutils-5.1.3/src/test.c.old 2006-08-17 15:29:41.000000000 +0100
++++ coreutils-5.1.3/src/test.c 2006-08-17 15:30:44.000000000 +0100
+@@ -125,7 +125,7 @@
+ /* Do the same thing access(2) does, but use the effective uid and gid. */
+
+ static int
+-eaccess (char const *file, int mode)
++_eaccess (char const *file, int mode)
+ {
+ static int have_ids;
+ static uid_t uid, euid;
+@@ -158,7 +158,7 @@
+ return result;
+ }
+ #else
+-# define eaccess(F, M) euidaccess (F, M)
++# define _eaccess(F, M) euidaccess (F, M)
+ #endif
+
+ /* Increment our position in the argument list. Check that we're not
+@@ -623,17 +623,17 @@
+
+ case 'r': /* file is readable? */
+ unary_advance ();
+- value = -1 != eaccess (argv[pos - 1], R_OK);
++ value = -1 != _eaccess (argv[pos - 1], R_OK);
+ return (TRUE == value);
+
+ case 'w': /* File is writable? */
+ unary_advance ();
+- value = -1 != eaccess (argv[pos - 1], W_OK);
++ value = -1 != _eaccess (argv[pos - 1], W_OK);
+ return (TRUE == value);
+
+ case 'x': /* File is executable? */
+ unary_advance ();
+- value = -1 != eaccess (argv[pos - 1], X_OK);
++ value = -1 != _eaccess (argv[pos - 1], X_OK);
+ return (TRUE == value);
+
+ case 'O': /* File is owned by you? */
diff --git a/packages/coreutils/coreutils_5.1.3.bb b/packages/coreutils/coreutils_5.1.3.bb
index 31af80907d..2f7476c2dd 100644
--- a/packages/coreutils/coreutils_5.1.3.bb
+++ b/packages/coreutils/coreutils_5.1.3.bb
@@ -3,11 +3,12 @@ SECTION = "base"
DESCRIPTION = "A collection of core GNU utilities."
RREPLACES = "textutils shellutils fileutils"
RPROVIDES = "textutils shellutils fileutils"
-PR = "r7"
+PR = "r8"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://install-cross.patch;patch=1;pnum=0 \
- file://man.patch;patch=1"
+ file://man.patch;patch=1 \
+ file://rename-eaccess.patch;patch=1"
inherit autotools