aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-08 08:11:25 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-08 08:11:25 +0000
commit0370bb86eb076c168f8bd7930c06c3f5d8a2f854 (patch)
tree5886b2141b1211467745d493518228068f805da5 /packages
parent3a89ce65aad826ad0a92c90de2fc81dcc72ddc36 (diff)
parentb8b9e106a7a2ee432ed3d102edeb22f25594321c (diff)
downloadopenembedded-0370bb86eb076c168f8bd7930c06c3f5d8a2f854.tar.gz
merge of 'dd905d1faac53a401f49cb464e9668c7754e986b'
and 'f14146eea70011b4bb6773d8401d0068d551f29d'
Diffstat (limited to 'packages')
-rw-r--r--packages/apache2/apache2-native_2.2.3.bb44
1 files changed, 22 insertions, 22 deletions
diff --git a/packages/apache2/apache2-native_2.2.3.bb b/packages/apache2/apache2-native_2.2.3.bb
index 9e4d42e254..f961d7863a 100644
--- a/packages/apache2/apache2-native_2.2.3.bb
+++ b/packages/apache2/apache2-native_2.2.3.bb
@@ -3,7 +3,7 @@ DEPENDS = "expat pcre"
inherit native
-PR="r4"
+PR="r5"
SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2"
S = "${WORKDIR}/httpd-${PV}"
@@ -13,32 +13,32 @@ do_configure () {
}
do_populate_staging () {
- cp srclib/pcre/dftables ../../../staging/i686-linux/bin/
- cp server/gen_test_char ../../../staging/i686-linux/bin/
- cp srclib/apr/apr-1-config ../../../staging/i686-linux/bin/
- cp srclib/apr-util/apu-1-config ../../../staging/i686-linux/bin/
- cp support/apxs ../../../staging/i686-linux/bin/
- chmod 755 ../../../staging/i686-linux/bin/apxs
- mkdir -p ../../../staging/build
- cp build/*.mk ../../../staging/build
+ cp srclib/pcre/dftables ${STAGING_BINDIR}
+ cp server/gen_test_char ${STAGING_BINDIR}
+ cp srclib/apr/apr-1-config ${STAGING_BINDIR}
+ cp srclib/apr-util/apu-1-config ${STAGING_BINDIR}
+ cp support/apxs ${STAGING_BINDIR}
+ chmod 755 ${STAGING_BINDIR}/apxs
+ mkdir -p ${STAGING_DIR}/build
+ cp build/*.mk ${STAGING_DIR}/build
cat build/config_vars.mk | \
- sed -e '/^prefix/s,staging,staging/i686-linux,' | \
+ sed -e '/^prefix/s,staging,staging/${HOST_SYS},' | \
sed -e '/^includedir/s,/include,/include/apache2,' | \
- sed -e 's,staging/bin,staging/i686-linux/bin,' > \
- ../../../staging/build/config_vars.mk
- cp build/instdso.sh ../../../staging/build
- cp .libs/httpd ../../../staging/i686-linux/bin
+ sed -e 's,staging/bin,staging/${HOST_SYS}/bin,' > \
+ ${STAGING_DIR}/build/config_vars.mk
+ cp build/instdso.sh ${STAGING_DIR}/build
+ cp .libs/httpd ${STAGING_BINDIR}
(cd srclib/apr/.libs; tar -cf - libapr-*.so* ) |
- (cd ../../../staging/i686-linux/lib; tar -xf - )
+ (cd ${STAGING_LIBDIR}; tar -xf - )
(cd srclib/apr-util/.libs; tar -cf - libaprutil-*.so* ) |
- (cd ../../../staging/i686-linux/lib; tar -xf - )
+ (cd ${STAGING_LIBDIR}; tar -xf - )
- mkdir -p ../../../staging/i686-linux/include/apache2
- cp include/* ../../../staging/i686-linux/include/apache2
- cp os/unix/os.h ../../../staging/i686-linux/include/apache2
- cp os/unix/unixd.h ../../../staging/i686-linux/include/apache2
+ mkdir -p ${STAGING_INCDIR}/apache2
+ cp include/* ${STAGING_INCDIR}/apache2
+ cp os/unix/os.h ${STAGING_INCDIR}/apache2
+ cp os/unix/unixd.h ${STAGING_INCDIR}/apache2
- cp support/envvars-std ../../../staging/i686-linux/bin/envvars
- chmod 755 ../../../staging/i686-linux/bin/envvars
+ cp support/envvars-std ${STAGING_BINDIR}/envvars
+ chmod 755 ${STAGING_BINDIR}/envvars
}