aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-11-24 19:27:48 +0000
committerKoen Kooi <koen@openembedded.org>2006-11-24 19:27:48 +0000
commit88f473fa5bb4c6f8c62feebc4e19547faade0218 (patch)
treea10c6c8022d4f062767796cda537f5b8127cf79d /packages
parent0b0bcb5391bd4c7173bace15601c5531c6f7c260 (diff)
downloadopenembedded-88f473fa5bb4c6f8c62feebc4e19547faade0218.tar.gz
btsco: stop configure from putting -I/usr/include into the commmand line, fixes the problems people where seeing in #oe
* config.log is a handy debug tool
Diffstat (limited to 'packages')
-rw-r--r--packages/btsco/btsco_0.42.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/packages/btsco/btsco_0.42.bb b/packages/btsco/btsco_0.42.bb
index 005f3715f5..a4dd11b197 100644
--- a/packages/btsco/btsco_0.42.bb
+++ b/packages/btsco/btsco_0.42.bb
@@ -9,3 +9,13 @@ inherit autotools pkgconfig
SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz"
S = "${WORKDIR}/${PN}-${PV}"
+
+CFLAGS += " -I${STAGING_INCDIR} "
+
+#there are some bogus macros putting -I/usr/include into C(PP)FLAGS, lets fix that
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ sed -i 's:-I${bluez_prefix}/include::g' configure
+ oe_runconf
+}