aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-25 15:49:16 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-27 14:11:32 +0100
commit4c95f1db4ba243dea7af2c9cd00271539dccbb62 (patch)
tree72b63bec5a784bdf1eda2ff8352a8f186c28cfcd /packages
parentfb87b496ca8298b7f1019a5718c3633ff5de6fbe (diff)
downloadopenembedded-4c95f1db4ba243dea7af2c9cd00271539dccbb62.tar.gz
automake: rediff path_prog_fixes for 1.10
* people should really test things before making it a global default. 'sane default' implies that at least do_patch succeeds
Diffstat (limited to 'packages')
-rw-r--r--packages/automake/automake-1.10/path_prog_fixes.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/automake/automake-1.10/path_prog_fixes.patch b/packages/automake/automake-1.10/path_prog_fixes.patch
new file mode 100644
index 0000000000..60d32833ea
--- /dev/null
+++ b/packages/automake/automake-1.10/path_prog_fixes.patch
@@ -0,0 +1,43 @@
+Index: automake-1.9.3/Makefile.am
+===================================================================
+--- automake-1.9.3.orig/Makefile.am 2004-10-25 14:57:30.000000000 -0400
++++ automake-1.9.3/Makefile.am 2005-03-09 16:47:38.241364016 -0500
+@@ -66,7 +66,8 @@
+ -e 's,[@]SHELL[@],$(SHELL),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
+- -e 's,[@]datadir[@],$(datadir),g'
++ -e 's,[@]datadir[@],$(datadir),g' \
++ -e 's,[@]bindir[@],$(bindir),g'
+
+ ## These files depend on Makefile so they are rebuilt if $(VERSION),
+ ## $(datadir) or other do_subst'ituted variables change.
+Index: automake-1.9.3/Makefile.in
+===================================================================
+--- automake-1.9.3.orig/Makefile.in 2004-11-01 05:23:54.000000000 -0500
++++ automake-1.9.3/Makefile.in 2005-03-09 16:47:54.712859968 -0500
+@@ -161,7 +161,8 @@
+ -e 's,[@]SHELL[@],$(SHELL),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
+- -e 's,[@]datadir[@],$(datadir),g'
++ -e 's,[@]datadir[@],$(datadir),g' \
++ -e 's,[@]bindir[@],$(bindir),g'
+
+ WGET = wget
+ WGETSGO = $(WGET) http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~
+--- /tmp/aclocal.in 2009-02-25 15:43:38.000000000 +0100
++++ automake-1.10/aclocal.in 2009-02-25 15:44:54.000000000 +0100
+@@ -1,8 +1,10 @@
+-#!@PERL@ -w
++#!@bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
+ if 0;
+
+ # aclocal - create aclocal.m4 by scanning configure.ac