aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-06-06 14:40:04 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-06-06 14:40:04 +0000
commit5b3d3202deb418a9234596c2f332788e92ee24e9 (patch)
treefa14b5f73c08e483034d6491ae196d4680fa21b9 /packages
parent1c4b9cfb6f0a3967ca16513150658a488efa3e85 (diff)
parenta7078c7115a562d138da6498119e27b143e12810 (diff)
downloadopenembedded-5b3d3202deb418a9234596c2f332788e92ee24e9.tar.gz
merge of '8c882ebf352023c6daf9ea756d94b90aef6d21ba'
and 'e39129641bd214aff1dd438b4331a2f1531ca1cc'
Diffstat (limited to 'packages')
-rw-r--r--packages/fltk/files/.mtn2git_empty0
-rw-r--r--packages/fltk/files/disable_test.patch13
-rw-r--r--packages/fltk/fltk_1.1.9.bb35
3 files changed, 48 insertions, 0 deletions
diff --git a/packages/fltk/files/.mtn2git_empty b/packages/fltk/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fltk/files/.mtn2git_empty
diff --git a/packages/fltk/files/disable_test.patch b/packages/fltk/files/disable_test.patch
new file mode 100644
index 0000000000..8c01a1f806
--- /dev/null
+++ b/packages/fltk/files/disable_test.patch
@@ -0,0 +1,13 @@
+Index: fltk-1.1.9/Makefile
+===================================================================
+--- fltk-1.1.9.orig/Makefile 2008-06-06 16:14:11.936736201 +0200
++++ fltk-1.1.9/Makefile 2008-06-06 16:14:22.526357637 +0200
+@@ -27,7 +27,7 @@
+
+ include makeinclude
+
+-DIRS = $(IMAGEDIRS) src fluid test documentation
++DIRS = $(IMAGEDIRS) src fluid documentation
+
+ all: makeinclude fltk-config
+ for dir in $(DIRS); do\
diff --git a/packages/fltk/fltk_1.1.9.bb b/packages/fltk/fltk_1.1.9.bb
new file mode 100644
index 0000000000..a2c5dcb5ab
--- /dev/null
+++ b/packages/fltk/fltk_1.1.9.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
+HOMEPAGE = "http://www.fltk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \
+ file://disable_test.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/fltk-${PV}"
+
+inherit lib_package autotools binconfig
+
+EXTRA_OECONF = "--enable-shared \
+ --enable-threads \
+ --enable-xdbe --enable-xft --enable-gl \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d)
+}
+
+LEAD_SONAME = "libfltk.so"