aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-02-25 20:34:02 -0600
committerMike Westerhof <mwester@dls.net>2009-02-25 20:34:02 -0600
commita64be907e3e038af29d7f4184971f10a7a0dec82 (patch)
treebc83c47ec6dfba9f9698c7cfb45da72e71f20a9b /packages
parent50e689eec4e3dfe13d0e7a090d3173d315787af0 (diff)
downloadopenembedded-a64be907e3e038af29d7f4184971f10a7a0dec82.tar.gz
SlugOS: reinstate fakeroot 1.9.6 and set as the PREFERRED_VERSION
Diffstat (limited to 'packages')
-rw-r--r--packages/fakeroot/fakeroot-1.9.6/configure-libtool.patch18
-rw-r--r--packages/fakeroot/fakeroot-1.9.6/fix-prefix.patch18
-rw-r--r--packages/fakeroot/fakeroot-native_1.9.6.bb21
-rw-r--r--packages/fakeroot/fakeroot_1.9.6.bb18
4 files changed, 75 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot-1.9.6/configure-libtool.patch b/packages/fakeroot/fakeroot-1.9.6/configure-libtool.patch
new file mode 100644
index 0000000000..8830328eb5
--- /dev/null
+++ b/packages/fakeroot/fakeroot-1.9.6/configure-libtool.patch
@@ -0,0 +1,18 @@
+--- fakeroot-1.8.3/configure.ac.orig 2007-10-31 00:17:27.000000000 -0500
++++ fakeroot-1.8.3/configure.ac 2007-10-31 00:18:12.000000000 -0500
+@@ -1,14 +1,12 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+
+ AC_ARG_WITH([ipc],
+ AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],
diff --git a/packages/fakeroot/fakeroot-1.9.6/fix-prefix.patch b/packages/fakeroot/fakeroot-1.9.6/fix-prefix.patch
new file mode 100644
index 0000000000..3884aca01c
--- /dev/null
+++ b/packages/fakeroot/fakeroot-1.9.6/fix-prefix.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- fakeroot-1.2.13/scripts/fakeroot.in~fix-prefix
++++ fakeroot-1.2.13/scripts/fakeroot.in
+@@ -15,8 +15,8 @@
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-PREFIX=@prefix@
+-BINDIR=@bindir@
++BINDIR=`dirname $0`
++PREFIX=`dirname ${BINDIR}`
+
+ LIB=lib@fakeroot_transformed@.so.0
+ PATHS=@libdir@:${PREFIX}/lib64/libfakeroot:${PREFIX}/lib32/libfakeroot
diff --git a/packages/fakeroot/fakeroot-native_1.9.6.bb b/packages/fakeroot/fakeroot-native_1.9.6.bb
new file mode 100644
index 0000000000..77d6f58651
--- /dev/null
+++ b/packages/fakeroot/fakeroot-native_1.9.6.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
diff --git a/packages/fakeroot/fakeroot_1.9.6.bb b/packages/fakeroot/fakeroot_1.9.6.bb
new file mode 100644
index 0000000000..aaf696d79d
--- /dev/null
+++ b/packages/fakeroot/fakeroot_1.9.6.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/fakeroot
+ install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+ autotools_stage_all
+}