aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2005-09-22 21:34:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-22 21:34:06 +0000
commit1511edfb4338f3cb2e1082c00ee91a6d040453e3 (patch)
tree40e90e432f8886513c2f06a1989bad5cc4d1652a /packages
parent3d93c6e8a04292859eef29ed4472be3b09a4fc11 (diff)
parentc718f3aa73e40ab86cb839cb9af4c23ba347cf61 (diff)
downloadopenembedded-1511edfb4338f3cb2e1082c00ee91a6d040453e3.tar.gz
merge of a60d3fd56109a66320e32c0f8aa0af61036586a2
and d08b1028598c89e26738182a8271ca038bd0f5b5
Diffstat (limited to 'packages')
-rw-r--r--packages/pmount/files/mmc-fix.patch20
-rw-r--r--packages/pmount/pmount_0.9.4.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/packages/pmount/files/mmc-fix.patch b/packages/pmount/files/mmc-fix.patch
new file mode 100644
index 0000000000..3376a503c7
--- /dev/null
+++ b/packages/pmount/files/mmc-fix.patch
@@ -0,0 +1,20 @@
+--- pmount-0.9.4/policy.c.orig 2005-09-22 23:11:29 +0200
++++ pmount-0.9.4/policy.c 2005-09-22 23:12:54 +0200
+@@ -354,7 +354,7 @@
+ device_removable( const char* device )
+ {
+ struct sysfs_device *dev;
+- static char* hotplug_buses[] = { "usb", "ieee1394", NULL };
++ static char* hotplug_buses[] = { "usb", "ieee1394", "mmc", NULL };
+ int removable;
+ char blockdevpath[PATH_MAX];
+
+@@ -370,7 +370,7 @@
+ /* check whether device has "removable" attribute with value '1' */
+ removable = get_blockdev_attr( blockdevpath, "removable" );
+
+- /* if not, fall back to bus scanning (regard USB and FireWire as removable) */
++ /* if not, fall back to bus scanning (regard USB, FireWire and MMC as removable) */
+ if( !removable )
+ removable = find_bus_ancestry( dev, hotplug_buses );
+ sysfs_close_device( dev );
diff --git a/packages/pmount/pmount_0.9.4.bb b/packages/pmount/pmount_0.9.4.bb
index ceb0d070c7..72492a5958 100644
--- a/packages/pmount/pmount_0.9.4.bb
+++ b/packages/pmount/pmount_0.9.4.bb
@@ -1,8 +1,9 @@
DESCRIPTION="mount removable devices as normal user"
DEPENDS="sysfsutils"
-PR="r0"
+PR="r1"
SRC_URI="http://www.piware.de/projects/pmount-0.9.4.tar.gz \
+ file://mmc-fix.patch;patch=1 \
file://no-hal.patch;patch=1"
do_install() {