aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-06-29 15:36:20 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-06-29 15:36:20 +0000
commit578a753112bdc125f1dccdb0796f61d30aff0c31 (patch)
treec9edaf14e9ace431903df09a6f1fa7189ed14592 /packages
parent2e49eaa50bbcdd10ce8eadb3c97bea08ac98fd80 (diff)
downloadopenembedded-578a753112bdc125f1dccdb0796f61d30aff0c31.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/06/29 17:35:49+02:00 uni-frankfurt.de!mickeyl opie-ttf-support: Compile hrw's update-qtttffontdir instead of hardcoding the fontdir BKrev: 42c2bff42ZCerw-Ir7z61XPTARtL5Q
Diffstat (limited to 'packages')
-rw-r--r--packages/opie-ttf-support/files/update-qtttffontdir.c0
-rw-r--r--packages/opie-ttf-support/opie-ttf-support_1.0.0.bb28
2 files changed, 28 insertions, 0 deletions
diff --git a/packages/opie-ttf-support/files/update-qtttffontdir.c b/packages/opie-ttf-support/files/update-qtttffontdir.c
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/opie-ttf-support/files/update-qtttffontdir.c
diff --git a/packages/opie-ttf-support/opie-ttf-support_1.0.0.bb b/packages/opie-ttf-support/opie-ttf-support_1.0.0.bb
index e69de29bb2..15b4905aff 100644
--- a/packages/opie-ttf-support/opie-ttf-support_1.0.0.bb
+++ b/packages/opie-ttf-support/opie-ttf-support_1.0.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Meta-package for Opie TTF support"
+DEPENDS = "freetype opie-freetype"
+RDEPENDS = "opie-freetype"
+SECTION = "opie/fonts"
+PR = "r2"
+
+SRC_URI = "file://update-qtttffontdir.c"
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -I${STAGING_INCDIR}/freetype2 -lfreetype -o update-qtttffontdir update-qtttffontdir.c
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 update-qtttffontdir ${D}${sbindir}
+}
+
+pkg_postinst() {
+#!/bin/sh
+if [ -n "$D" ]
+then
+ ${sbindir}/update-qtttffontdir /usr/local/share/fonts/truetype >/opt/QtPalmtop/lib/fonts/fontdir
+ exit 0
+else
+ exit 1
+fi
+}