aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-15 02:59:57 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-15 02:59:57 +0000
commitc8ad9b636344a94a164640323d129ca1e8ced4b8 (patch)
tree5bf7eebec4e6dd0d78412470c879cd5adc192e29 /packages
parent5c43290bf342418b7aac7e3379354a9e188ba194 (diff)
downloadopenembedded-c8ad9b636344a94a164640323d129ca1e8ced4b8.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/14 23:23:48+01:00 uni-frankfurt.de!mickeyl first shot at cleaning up the font situation in qte: split common qte fonts out of the libqte2 build and add qpf-qte-fonts BKrev: 421165adRfbQU8xN4DMHmTMjHWjSQQ
Diffstat (limited to 'packages')
-rw-r--r--packages/qpf-fonts/files/update-qtfontdir (renamed from packages/qte/qte-2.3.10/update-qtfontdir)0
-rw-r--r--packages/qpf-fonts/qpf-qte_2.3.10.bb0
-rw-r--r--packages/qpf-fonts/terminus.bb31
-rw-r--r--packages/qte/qte_2.3.10.bb87
4 files changed, 34 insertions, 84 deletions
diff --git a/packages/qte/qte-2.3.10/update-qtfontdir b/packages/qpf-fonts/files/update-qtfontdir
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-2.3.10/update-qtfontdir
+++ b/packages/qpf-fonts/files/update-qtfontdir
diff --git a/packages/qpf-fonts/qpf-qte_2.3.10.bb b/packages/qpf-fonts/qpf-qte_2.3.10.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qpf-fonts/qpf-qte_2.3.10.bb
diff --git a/packages/qpf-fonts/terminus.bb b/packages/qpf-fonts/terminus.bb
index e69de29bb2..68e569ea28 100644
--- a/packages/qpf-fonts/terminus.bb
+++ b/packages/qpf-fonts/terminus.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Qt/Embedded terminus font"
+HOMEPAGE = "http://www.is-vn.bg/hamster/jimmy-en.html"
+SECTION = "opie/fonts"
+PRIORITY = "optional"
+MAINTAINER = "M&N Solutions GmbH <info@mn-solutions.de>"
+LICENSE = "GPL"
+RDEPENDS = "qte-fonts-common"
+PACKAGE_ARCH = "all"
+PV = "1.0"
+PR = "r1"
+
+SRC_URI = "http://www.mn-solutions.de/downloads/mnci/terminus-fonts.tar.bz2"
+S = ${WORKDIR}/terminus-fonts
+
+
+do_install() {
+ mkdir -p ${D}${palmqtdir}/lib/fonts
+ cp *.qpf ${D}${palmqtdir}/lib/fonts
+}
+
+PACKAGES = "qpf-terminus"
+FILES = ""
+FILES_qpf-terminus = "${palmqtdir}/lib/fonts"
+
+pkg_postinst() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
diff --git a/packages/qte/qte_2.3.10.bb b/packages/qte/qte_2.3.10.bb
index a751dabcfb..f379aa3de1 100644
--- a/packages/qte/qte_2.3.10.bb
+++ b/packages/qte/qte_2.3.10.bb
@@ -5,7 +5,7 @@ MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL QPL"
DEPENDS = "zlib libpng jpeg tslib uicmoc-native"
PROVIDES = "virtual/qte virtual/libqte2"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
file://qpe.patch;patch=1 \
@@ -21,7 +21,6 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
file://simpad.patch;patch=1 \
file://handhelds.patch;patch=1 \
file://qiconview-speed.patch;patch=1 \
- file://update-qtfontdir \
file://sharp_char.h \
file://switches.h "
@@ -107,87 +106,7 @@ do_stage() {
}
do_install() {
- install -d ${D}/${sbindir}/
- install -m 0755 ${WORKDIR}/update-qtfontdir ${D}/${sbindir}/
- install -d ${D}${palmtopdir}/lib/fonts/
- oe_libinstall -so -C lib libqte ${D}/${palmtopdir}/lib
- cp -a lib/fonts/* ${D}${palmtopdir}/lib/fonts/
+ oe_libinstall -so -C lib libqte ${D}/${palmqtdir}/lib/
}
-pkg_postinst() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-unicode() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-lcd () {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-japanese() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-micro() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-courier() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-PACKAGES = "libqte2 qte-font-fixed qte-font-helvetica-small qte-font-helvetica-large \
- qte-font-smoothtimes qte-font-smallsmooth qte-font-unicode qte-font-lcd \
- qte-font-japanese qte-font-micro qte-font-courier"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FILES_${PN} = ""
-FILES_libqte2 = "${palmtopdir}/lib/libqte.so* /usr/sbin/update-qtfontdir"
-FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
-PACKAGE_ARCH_qte-font-fixed = "all"
-FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
- ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
-PACKAGE_ARCH_qte-font-helvetica-small = "all"
-FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
- ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
-PACKAGE_ARCH_qte-font-helvetica-large = "all"
-FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
-PACKAGE_ARCH_qte-font-smoothtimes = "all"
-FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
-PACKAGE_ARCH_qte-font-smallsmooth = "all"
-FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
-PACKAGE_ARCH_qte-font-unicode = "all"
-FILES_qte-font-lcd = "${palmtopdir}/lib/fonts/lcd*"
-PACKAGE_ARCH_qte-font-lcd = "all"
-FILES_qte-font-japanese = "${palmtopdir}/lib/fonts/japanese*"
-PACKAGE_ARCH_qte-font-japanese = "all"
-FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"
-PACKAGE_ARCH_qte-font-micro = "all"
-FILES_qte-font-courier = "${palmtopdir}/lib/fonts/cour*"
-PACKAGE_ARCH_qte-font-courier = "all"
+FILES_${PN} = "${palmqtdir}"