aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-11-27 16:59:23 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-11-27 16:59:23 +0000
commit28ac67add5c6134ee7227a2352361e2de5b06ed7 (patch)
tree78e2c47b74fb2e7eca629ed791f81286018039b2 /packages
parent32e54b21485668cb3c388a197bfc8815be89f8c2 (diff)
downloadopenembedded-28ac67add5c6134ee7227a2352361e2de5b06ed7.tar.gz
libexif: added 0.6.13
Diffstat (limited to 'packages')
-rw-r--r--packages/libexif/libexif_0.6.13.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/libexif/libexif_0.6.13.bb b/packages/libexif/libexif_0.6.13.bb
new file mode 100644
index 0000000000..9f3136798f
--- /dev/null
+++ b/packages/libexif/libexif_0.6.13.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+HOMEPAGE = "http://sourceforge.net/projects/libexif"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libexif
+ for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-utils.h exif-log.h exif-mnote-data.h _stdint.h
+ do
+ install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
+ done
+}