aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2007-08-12 10:24:39 +0000
committerRichard Purdie <rpurdie@rpsys.net>2007-08-12 10:24:39 +0000
commit448fe64a69226b019c9f4ba217b5fb63e04a43f6 (patch)
tree03e7aef947ac8161d9580afcecd21cf7608a6b50 /packages
parent91ba719f69aa81e8084ac4602268b1d10b55b7dc (diff)
downloadopenembedded-448fe64a69226b019c9f4ba217b5fb63e04a43f6.tar.gz
meta-maemo: Split into a tasks package and remove uneeded immediate expansions
Diffstat (limited to 'packages')
-rw-r--r--packages/meta/meta-maemo.bb95
-rw-r--r--packages/tasks/task-maemo.bb73
2 files changed, 81 insertions, 87 deletions
diff --git a/packages/meta/meta-maemo.bb b/packages/meta/meta-maemo.bb
index 94197d07cf..72216a6304 100644
--- a/packages/meta/meta-maemo.bb
+++ b/packages/meta/meta-maemo.bb
@@ -1,90 +1,11 @@
-PACKAGES = "maemo-task-base maemo-task-apps maemo-task-libs-install maemo-task-theme"
DESCRIPTION = "Meta-package for maemo environment"
-PR = "r8"
-
-ALLOW_EMPTY = "1"
-
-maemo-base-depends = "\
- diet-x11 \
- virtual/xserver \
- xpext \
- xsp"
-
-RDEPENDS_maemo-base-depends := "${maemo-base-depends}"
-DEPENDS += " ${maemo-base-depends}"
-
-maemo-task-libs-install = "\
- libsqlite \
- hildon-lgpl \
- libhildonbase \
- libhildonwidgets \
- hildon-fm"
-
-RDEPENDS_maemo-task-libs-install := "${maemo-task-libs-install}"
-
-
-maemo-task-base = "\
- bluez-utils-dbus \
- matchbox \
- shared-mime-info \
- rxvt-unicode \
- xst \
- xhost \
- xrdb \
- libgtkstylus \
- outo \
- hildon-initscripts \
- libosso \
- osso-af-utils \
- osso-af-startup \
- osso-core-config \
- osso-gnome-vfs2 \
- osso-thumbnail \
- xauth \
- esd"
-
-RDEPENDS_maemo-task-base := "gdk-pixbuf-loader-png \
- gdk-pixbuf-loader-xpm \
- gdk-pixbuf-loader-jpeg \
- pango-module-basic-x \
- pango-module-basic-fc \
- ${maemo-task-base}"
-
-DEPENDS += " ${maemo-task-base}"
-
-
-maemo-task-theme = "\
- xcursor-transparent-theme \
- sdk-default-theme \
- sdk-default-theme-config \
- sdk-default-icons \
- sapwood \
- ttf-bitstream-vera \
- sapwood \
- osso-sounds"
-
-RDEPENDS_maemo-task-theme := "${maemo-task-theme}"
-
-DEPENDS += " ${maemo-task-theme}"
-
-
-
-maemo-task-apps = "\
- osso-gwobex \
- osso-gwconnect \
- osso-bttools \
- hildon-status-bar \
- hildon-home \
- hildon-navigator \
- hildon-control-panel \
- osso-application-installer \
- osso-app-killer \
- osso-screenshot-tool \
- gpe-todo-hildon \
- gpe-contacts-hildon \
- gpe-mini-browser-hildon"
+LICENSE = "MIT"
+PR = "r0"
-RDEPENDS_maemo-task-apps := "${maemo-task-apps}"
-DEPENDS += " ${maemo-task-apps}"
+RDEPENDS = "\
+ maemo-task-base \
+ maemo-task-apps \
+ maemo-task-libs-install \
+ maemo-task-theme"
-LICENSE = "MIT"
+inherit meta \ No newline at end of file
diff --git a/packages/tasks/task-maemo.bb b/packages/tasks/task-maemo.bb
new file mode 100644
index 0000000000..a4f16ac3a4
--- /dev/null
+++ b/packages/tasks/task-maemo.bb
@@ -0,0 +1,73 @@
+DESCRIPTION = "Task package for maemo environment"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+PR = "r0"
+
+PACKAGES = "\
+ maemo-task-base \
+ maemo-task-apps \
+ maemo-task-libs-install \
+ maemo-task-theme"
+
+RDEPENDS_maemo-base-depends = "\
+ diet-x11 \
+ virtual/xserver \
+ xpext \
+ xsp"
+
+RDEPENDS_maemo-task-libs-install = "\
+ libsqlite \
+ hildon-lgpl \
+ libhildonbase \
+ libhildonwidgets \
+ hildon-fm"
+
+RDEPENDS_maemo-task-base = "\
+ gdk-pixbuf-loader-png \
+ gdk-pixbuf-loader-xpm \
+ gdk-pixbuf-loader-jpeg \
+ pango-module-basic-x \
+ pango-module-basic-fc \
+ bluez-utils-dbus \
+ matchbox \
+ shared-mime-info \
+ rxvt-unicode \
+ xst \
+ xhost \
+ xrdb \
+ libgtkstylus \
+ outo \
+ hildon-initscripts \
+ libosso \
+ osso-af-utils \
+ osso-af-startup \
+ osso-core-config \
+ osso-gnome-vfs2 \
+ osso-thumbnail \
+ xauth \
+ esd"
+
+RDEPENDS_maemo-task-theme = "\
+ xcursor-transparent-theme \
+ sdk-default-theme \
+ sdk-default-theme-config \
+ sdk-default-icons \
+ sapwood \
+ ttf-bitstream-vera \
+ sapwood \
+ osso-sounds"
+
+RDEPENDS_maemo-task-apps = "\
+ osso-gwobex \
+ osso-gwconnect \
+ osso-bttools \
+ hildon-status-bar \
+ hildon-home \
+ hildon-navigator \
+ hildon-control-panel \
+ osso-application-installer \
+ osso-app-killer \
+ osso-screenshot-tool \
+ gpe-todo-hildon \
+ gpe-contacts-hildon \
+ gpe-mini-browser-hildon"