aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorccsmart <ccsmart@smartpal.de>2005-09-16 14:41:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-16 14:41:09 +0000
commit63b953a884d78372cfe22908014f12f0892db4e1 (patch)
treec975864c9acfe80d6d00c7ebc3f7a1979b396ae3 /packages
parenta53f01fcd7d5652feb9f161d94e79fa6445c7cf1 (diff)
parentf5fb2e35fa9b4877beeb3aa81f43e47cd0582405 (diff)
downloadopenembedded-63b953a884d78372cfe22908014f12f0892db4e1.tar.gz
merge of 31484b3a457e2e2ecbac527a3655dd4adcd81277
and 36fdf65c91bd73e2934ded7c2f8bdc1714cfa51e
Diffstat (limited to 'packages')
-rw-r--r--packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb25
-rw-r--r--packages/linux/linux-openzaurus_2.6.13-mm3.bb18
2 files changed, 34 insertions, 9 deletions
diff --git a/packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb b/packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb
new file mode 100644
index 0000000000..1ecc553cf9
--- /dev/null
+++ b/packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb
@@ -0,0 +1,25 @@
+SECTION = "kernel"
+DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+LICENSE = "GPL"
+#
+COMPATIBLE_HOST = "arm.*-linux"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')}"
+
+S = "${WORKDIR}/kernel26"
+
+inherit kernel
+
+K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
+K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
+K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
+HHV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
+
+KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
+do_configure() {
+ install -m 0644 arch/arm/configs/ipaqpxa_defconfig .config
+ yes '' | oe_runmake oldconfig
+}
diff --git a/packages/linux/linux-openzaurus_2.6.13-mm3.bb b/packages/linux/linux-openzaurus_2.6.13-mm3.bb
index 1213b8416a..cc9ec6df0d 100644
--- a/packages/linux/linux-openzaurus_2.6.13-mm3.bb
+++ b/packages/linux/linux-openzaurus_2.6.13-mm3.bb
@@ -28,6 +28,10 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.13.tar.gz \
${RPSRC}/sharpsl_mtd_extras-r1.patch;patch=1 \
${RPSRC}/ohci_portcount-r0.patch;patch=1 \
${RPSRC}/pxa_ohci_power-r0.patch;patch=1 \
+ ${RPSRC}/corgi_cleanup-r0.patch;patch=1 \
+ ${RPSRC}/poodle_cleanup-r0.patch;patch=1 \
+ ${RPSRC}/poodle_mmc-r0.patch;patch=1 \
+ ${RPSRC}/poodle_irda-r0.patch;patch=1 \
${RPSRC}/pxa_i2c_fixes-r0.patch;patch=1 \
${RPSRC}/spitz_usbsuspend-r0.patch;patch=1 \
${RPSRC}/pxa_ohci_platform-r0.patch;patch=1 \
@@ -35,16 +39,12 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.13.tar.gz \
${RPSRC}/corgi_pm-r3.patch;patch=1 \
${RPSRC}/spitz_base_extras-r2.patch;patch=1 \
${RPSRC}/spitz_pm-r3.patch;patch=1 \
- ${RPSRC}/corgi_cleanup-r0.patch;patch=1 \
- ${RPSRC}/poodle_cleanup-r0.patch;patch=1 \
- ${RPSRC}/poodle_mmc-r0.patch;patch=1 \
- ${RPSRC}/poodle_irda-r0.patch;patch=1 \
${RPSRC}/scoop_collie_fix-r0.patch;patch=1 \
${RPSRC}/spitz_kbd_fix1-r0.patch;patch=1 \
${RPSRC}/spitzcf-r3.patch;patch=1 \
${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
${RPSRC}/pxa_remove_static-r0.patch;patch=1 \
- ${RPSRC}/pxa_irda-r3.patch;patch=1 \
+ ${RPSRC}/pxa_irda-r4.patch;patch=1 \
${RPSRC}/corgi_irda-r3.patch;patch=1 \
${RPSRC}/pxa_rtc-r1.patch;patch=1 \
${RPSRC}/scoop_susres-r1.patch;patch=1 \
@@ -53,15 +53,15 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.13.tar.gz \
${RPSRC}/sharpsl_bl_kick-r1.patch;patch=1 \
${RPSRC}/corgi_snd-r10.patch;patch=1 \
${RPSRC}/ipaq/hx2750_base-r20.patch;patch=1 \
- ${RPSRC}/ipaq/hx2750_bl-r1.patch;patch=1 \
+ ${RPSRC}/ipaq/hx2750_bl-r2.patch;patch=1 \
${RPSRC}/ipaq/hx2750_pcmcia-r1.patch;patch=1 \
${RPSRC}/ipaq/pxa_keys-r2.patch;patch=1 \
- ${RPSRC}/ipaq/tsc2101-r7.patch;patch=1 \
+ ${RPSRC}/ipaq/tsc2101-r8.patch;patch=1 \
${RPSRC}/ipaq/hx2750_test1-r2.patch;patch=1 \
${DOSRC}/pxa2xx-ir-dma-r0.patch;patch=1 \
${DOSRC}/tc6393-device-r5.patch;patch=1 \
${DOSRC}/tc6393_nand-r6.patch;patch=1 \
- ${DOSRC}/tosa-machine-base-r11.patch;patch=1 \
+ ${DOSRC}/tosa-machine-base-r12.patch;patch=1 \
${DOSRC}/tosa-keyboard-r6.patch;patch=1 \
${RPSRC}/temp/tc6393fb-r7.patch;patch=1 \
${DOSRC}/tosa-power-r6.patch;patch=1 \
@@ -69,7 +69,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.13.tar.gz \
${DOSRC}/tosa-udc-r4.patch;patch=1 \
${DOSRC}/tosa-irda-r3.patch;patch=1 \
${DOSRC}/tosa-lcd-r3.patch;patch=1 \
- ${DOSRC}/tosa-bl-r5.patch;patch=1 \
+ ${RPSRC}/temp/tosa-bl-r7.patch;patch=1 \
${RPSRC}/pcmcia_dev_ids-r1.patch;patch=1 \
${RPSRC}/mmc_timeout-r0.patch;patch=1 \
${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1 \