aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-11-27 21:34:27 +0000
committerMatt Reimer <mattjreimer@gmail.com>2006-11-27 21:34:27 +0000
commit9d82a24d4c13533fe0ae8a026bc846e6077e94e6 (patch)
tree65d38edceeb8ca5f4f4322111194d8a5c92eeaf2 /packages
parent32e54b21485668cb3c388a197bfc8815be89f8c2 (diff)
downloadopenembedded-9d82a24d4c13533fe0ae8a026bc846e6077e94e6.tar.gz
mplayer_1.0pre8.bb: Add a patch to hook up the imageon driver (making it
actually usable), and build the imageon driver for hx4700 as well.
Diffstat (limited to 'packages')
-rw-r--r--packages/mplayer/files/imageon-video_out.patch20
-rw-r--r--packages/mplayer/mplayer_1.0pre8.bb5
2 files changed, 24 insertions, 1 deletions
diff --git a/packages/mplayer/files/imageon-video_out.patch b/packages/mplayer/files/imageon-video_out.patch
new file mode 100644
index 0000000000..fcb7953c1b
--- /dev/null
+++ b/packages/mplayer/files/imageon-video_out.patch
@@ -0,0 +1,20 @@
+--- mplayer/libvo/video_out.c.orig 2006-11-27 12:49:51.000000000 -0800
++++ mplayer/libvo/video_out.c 2006-11-27 12:41:59.000000000 -0800
+@@ -87,6 +87,7 @@ extern vo_functions_t video_out_syncfb;
+ extern vo_functions_t video_out_fbdev;
+ extern vo_functions_t video_out_fbdev2;
+ extern vo_functions_t video_out_w100;
++extern vo_functions_t video_out_imageon;
+ extern vo_functions_t video_out_svga;
+ extern vo_functions_t video_out_png;
+ extern vo_functions_t video_out_ggi;
+@@ -200,6 +201,9 @@ vo_functions_t* video_out_drivers[] =
+ #ifdef HAVE_W100
+ &video_out_w100,
+ #endif
++#ifdef HAVE_IMAGEON
++ &video_out_imageon,
++#endif
+ #ifdef HAVE_SVGALIB
+ &video_out_svga,
+ #endif
diff --git a/packages/mplayer/mplayer_1.0pre8.bb b/packages/mplayer/mplayer_1.0pre8.bb
index b5af659fe9..c59c30e316 100644
--- a/packages/mplayer/mplayer_1.0pre8.bb
+++ b/packages/mplayer/mplayer_1.0pre8.bb
@@ -17,7 +17,8 @@ SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
file://libmpdemux-ogg-include.patch;patch=1 \
file://libmpcodecs-ogg-include.patch;patch=1 \
file://pld-onlyarm5.patch;patch=1 \
- ${SOURCEFORGE_MIRROR}/libw100/mplayer-imageon.patch;patch=1"
+ ${SOURCEFORGE_MIRROR}/libw100/mplayer-imageon.patch;patch=1 \
+ file://imageon-video_out.patch;patch=1"
RCONFLICTS_${PN} = "mplayer-atty"
RREPLACES_${PN} = "mplayer-atty"
@@ -26,6 +27,7 @@ PR = "r3"
PARALLEL_MAKE = ""
DEPENDS_append_c7x0 = " sharp-aticore-oss libw100 "
+DEPENDS_append_hx4700 = " libw100 "
S = "${WORKDIR}/MPlayer-${PV}"
@@ -168,6 +170,7 @@ EXTRA_OECONF = " \
"
EXTRA_OECONF_append_c7x0 = " --enable-w100 --enable-imageon "
+EXTRA_OECONF_append_hx4700 = " --enable-imageon "
do_configure() {
cp ${WORKDIR}/vo_w100.c ${S}/libvo