aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2005-09-18 15:18:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-18 15:18:33 +0000
commitdaf87f10c7967670ac52ef43178da19e278ad919 (patch)
tree88044f3d62d262a939f1b0601855216c01e1d5f6 /packages
parent632dbffeb2cb1c0533fe7650d4331b8e0fbc5e6d (diff)
parent0da38f02c716eace6b9be8e5217c93072c49108b (diff)
downloadopenembedded-daf87f10c7967670ac52ef43178da19e278ad919.tar.gz
merge of a8e888a8558f7e09b0116a15e86437cbee47b180
and b9817db6eb0bf96c168e419003466c7235191838
Diffstat (limited to 'packages')
-rw-r--r--packages/bogofilter/bogofilter_0.96.0.bb8
-rw-r--r--packages/bogofilter/files/bogohelper.sh12
-rw-r--r--packages/hostap/hostap-modules-0.4.4/kernel_updates.patch192
-rw-r--r--packages/meta/opie-image.bb2
-rw-r--r--packages/pcmciautils/pcmciautils_010.bb (renamed from packages/pcmciautils/pcmciautils_007.bb)4
-rw-r--r--packages/postfix/postfix_2.0.20.bb3
-rw-r--r--packages/ubahnnav/ubahnnav_0.3.1.bb32
-rw-r--r--packages/ubahnnav/ubahnnav_0.4.1.bb (renamed from packages/ubahnnav/ubahnnav_0.4.0.bb)9
8 files changed, 222 insertions, 40 deletions
diff --git a/packages/bogofilter/bogofilter_0.96.0.bb b/packages/bogofilter/bogofilter_0.96.0.bb
index dcef43d2a6..f9859481f0 100644
--- a/packages/bogofilter/bogofilter_0.96.0.bb
+++ b/packages/bogofilter/bogofilter_0.96.0.bb
@@ -4,13 +4,14 @@ DESCRIPTION = "Bogofilter is a mail filter that classifies mail as spam or ham (
by a statistical analysis of the message's header and content (body). \
The program is able to learn from the user's classifications and corrections."
LICENSE = "GPL"
-PR = "r2"
+PR = "r3"
PRIORITY = "optional"
SRC_URI = "http://download.sourceforge.net/bogofilter/bogofilter-${PV}.tar.bz2 \
file://${FILESDIR}/configure.ac.patch;patch=1 \
file://volatiles \
file://postfix-filter.sh \
+ file://bogohelper.sh \
"
inherit autotools
@@ -21,11 +22,16 @@ do_install_append () {
mkdir -p ${D}${sysconfdir}/default/volatiles
install -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/01_bogofilter
install -m 755 ${WORKDIR}/postfix-filter.sh ${D}${bindir}/postfix-filter.sh
+ install -m 755 ${WORKDIR}/bogohelper.sh ${D}${bindir}/bogohelper.sh
}
pkg_postinst () {
grep filter /etc/group || addgroup filter
grep spam /etc/passwd || adduser --disabled-password --home=/var/spool/filter --ingroup filter -g "Bogofilter" spam
grep bogo /etc/passwd || adduser --disabled-password --home=/home/bogo --ingroup filter -g "Bogofilter" bogo
+ [ -f "/etc/postfix/master.cf" ] && grep "/usr/bin/postfix-filter.sh" /etc/postfix/master.cf || {
+ echo "bogofilter unix - n n - - pipe" >> /etc/postfix/master.cf
+ echo " flags=R user=bogo argv=/usr/bin/postfix-filter.sh -f ${sender} -- ${recipient}" >> /etc/postfix/master.cf
+ }
/etc/init.d/populate-volatile.sh
}
diff --git a/packages/bogofilter/files/bogohelper.sh b/packages/bogofilter/files/bogohelper.sh
new file mode 100644
index 0000000000..5be7aeae7e
--- /dev/null
+++ b/packages/bogofilter/files/bogohelper.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+if [ -d "$2" ] ; then
+ echo -e "\ncd $2"
+ cd "$2"
+
+ for i in `find . -name '*.' -maxdepth 1` ; do
+ echo "bogofilter -d /opt/var/spool/bogofilter -t -v $1 < $i"
+ bogofilter -d /opt/var/spool/bogofilter -t -v "$1" < "$i"
+ done
+fi
+
diff --git a/packages/hostap/hostap-modules-0.4.4/kernel_updates.patch b/packages/hostap/hostap-modules-0.4.4/kernel_updates.patch
new file mode 100644
index 0000000000..aa8ba3e212
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.4.4/kernel_updates.patch
@@ -0,0 +1,192 @@
+Index: hostap-driver-0.4.4/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.4.4.orig/driver/modules/hostap_cs.c 2005-08-21 20:23:21.000000000 +0100
++++ hostap-driver-0.4.4/driver/modules/hostap_cs.c 2005-09-17 17:09:05.000000000 +0100
+@@ -207,12 +207,17 @@
+ #include "hostap_hw.c"
+
+
+-
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ static void prism2_detach(dev_link_t *link);
++#else
++static void prism2_detach(struct pcmcia_device *p_dev);
++#endif
++
+ static void prism2_release(u_long arg);
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ static int prism2_event(event_t event, int priority,
+ event_callback_args_t *args);
+-
++#endif
+
+ static int prism2_pccard_card_present(local_info_t *local)
+ {
+@@ -508,25 +513,36 @@
+ }
+ #endif
+
++static int prism2_config(dev_link_t *link);
+
+ /* allocate local data and register with CardServices
+ * initialize dev_link structure, but do not configure the card yet */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ static dev_link_t *prism2_attach(void)
++#else
++static int prism2_attach(struct pcmcia_device *p_dev)
++#endif
+ {
+ dev_link_t *link;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ client_reg_t client_reg;
+ int ret;
++#endif
+
+ link = kmalloc(sizeof(dev_link_t), GFP_KERNEL);
+ if (link == NULL)
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ return NULL;
+-
++#else
++ return -ENOMEM;
++#endif
+ memset(link, 0, sizeof(dev_link_t));
+
+ PDEBUG(DEBUG_HW, "%s: setting Vcc=33 (constant)\n", dev_info);
+ link->conf.Vcc = 33;
+ link->conf.IntType = INT_MEMORY_AND_IO;
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ /* register with CardServices */
+ link->next = dev_list;
+ dev_list = link;
+@@ -547,12 +563,28 @@
+ prism2_detach(link);
+ return NULL;
+ }
++
+ return link;
+-}
++#else
++ link->handle = p_dev;
++ p_dev->instance = link;
++
++ link->state |= DEV_PRESENT | DEV_CONFIG_PENDING;
++ prism2_config(link);
+
++ return 0;
++#endif
++}
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ static void prism2_detach(dev_link_t *link)
++#else
++static void prism2_detach(struct pcmcia_device *p_dev)
++#endif
+ {
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,14))
++ dev_link_t *link = dev_to_instance(p_dev);
++#endif
+ dev_link_t **linkp;
+
+ PDEBUG(DEBUG_FLOW, "prism2_detach\n");
+@@ -570,6 +602,7 @@
+ prism2_release((u_long)link);
+ }
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ if (link->handle) {
+ int res = pcmcia_deregister_client(link->handle);
+ if (res) {
+@@ -577,6 +610,7 @@
+ cs_error(link->handle, DeregisterClient, res);
+ }
+ }
++#endif
+
+ *linkp = link->next;
+ /* release net devices */
+@@ -855,7 +889,53 @@
+ PDEBUG(DEBUG_FLOW, "release - done\n");
+ }
+
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,14))
++static int prism2_suspend1(struct pcmcia_device *dev)
++{
++ dev_link_t *link = dev_to_instance(dev);
++ struct net_device *ndev = (struct net_device *) link->priv;
++
++ PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_SUSPEND\n", dev_info);
++ link->state |= DEV_SUSPEND;
++ /* fall through */
+
++ if (link->state & DEV_CONFIG) {
++ if (link->open) {
++ netif_stop_queue(ndev);
++ netif_device_detach(ndev);
++ }
++ prism2_suspend(ndev);
++ pcmcia_release_configuration(link->handle);
++ }
++
++ return 0;
++}
++
++static int prism2_resume1(struct pcmcia_device *dev)
++{
++ dev_link_t *link = dev_to_instance(dev);
++ struct net_device *ndev = (struct net_device *) link->priv;
++
++ PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_RESUME\n", dev_info);
++
++ link->state &= ~DEV_SUSPEND;
++ /* fall through */
++
++ if (link->state & DEV_CONFIG) {
++ pcmcia_request_configuration(link->handle, &link->conf);
++ prism2_hw_shutdown(ndev, 1);
++ prism2_hw_config(ndev, link->open ? 0 : 1);
++ if (link->open) {
++ netif_device_attach(ndev);
++ netif_start_queue(ndev);
++ }
++ }
++
++ return 0;
++}
++#endif
++
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ static int prism2_event(event_t event, int priority,
+ event_callback_args_t *args)
+ {
+@@ -924,7 +1004,7 @@
+ }
+ return 0;
+ }
+-
++#endif
+
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
+@@ -983,11 +1063,20 @@
+ .drv = {
+ .name = "hostap_cs",
+ },
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,14))
++ .probe = prism2_attach,
++ .remove = prism2_detach,
++ .suspend = prism2_suspend1,
++ .resume = prism2_resume1,
++#else
+ .attach = prism2_attach,
+ .detach = prism2_detach,
++#endif
+ .owner = THIS_MODULE,
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
+ .event = prism2_event,
++#endif
+ .id_table = hostap_cs_ids,
+ #endif
+ };
diff --git a/packages/meta/opie-image.bb b/packages/meta/opie-image.bb
index b1cf207656..20a3518fd7 100644
--- a/packages/meta/opie-image.bb
+++ b/packages/meta/opie-image.bb
@@ -8,7 +8,7 @@ FEED_URIS_append_familiar = " opie##http://familiar.handhelds.org/releases/${D
LICENSE = "MIT"
PR = "r18"
-DEPENDS = "meta-opie"
+DEPENDS = "task-bootstrap meta-opie"
extra_stuff := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles",d)}'
diff --git a/packages/pcmciautils/pcmciautils_007.bb b/packages/pcmciautils/pcmciautils_010.bb
index ad8cf7e2f4..dcaddbff83 100644
--- a/packages/pcmciautils/pcmciautils_007.bb
+++ b/packages/pcmciautils/pcmciautils_010.bb
@@ -1,5 +1,6 @@
-DESCRIPTION = "2.6 pcmcia utilities"
+DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
DEPENDS = "sysfsutils"
+HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
SECTION = "kernel/userland"
PRIORITY = "optional"
@@ -17,6 +18,7 @@ export hotplugdir = "${sysconfdir}/hotplug"
export pcmciaconfdir = "${sysconfdir}/pcmcia"
LD = "${CC}"
CFLAGS =+ "-I${S}/src"
+CFLAGS =+ '-DPCMCIAUTILS_VERSION=010'
PARALLEL_MAKE = ""
EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
diff --git a/packages/postfix/postfix_2.0.20.bb b/packages/postfix/postfix_2.0.20.bb
index 66839764b7..a676c3f809 100644
--- a/packages/postfix/postfix_2.0.20.bb
+++ b/packages/postfix/postfix_2.0.20.bb
@@ -1,7 +1,7 @@
SECTION = "console/network"
DEPENDS = "db3 pcre postfix-native"
LICENSE = "IPL"
-PR = "r6"
+PR = "r7"
SRC_URI = "ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-${PV}.tar.gz \
file://${FILESDIR}/makedefs.patch;patch=1 \
@@ -54,6 +54,7 @@ pkg_postinst () {
chmod g+s /usr/sbin/postqueue
chmod g+s /usr/sbin/postdrop
/var/tmp/main_cf.sh >/etc/postfix/main.cf
+ rm -f /var/tmp/main_cf.sh
chmod 644 /etc/postfix/main.cf
[ -d /var/spool/postfix ] && rmdir /var/spool/postfix
/etc/init.d/populate-volatile.sh
diff --git a/packages/ubahnnav/ubahnnav_0.3.1.bb b/packages/ubahnnav/ubahnnav_0.3.1.bb
deleted file mode 100644
index 01d1a8a192..0000000000
--- a/packages/ubahnnav/ubahnnav_0.3.1.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-DESCRIPTION = "U-Bahn Navigator helps you navigating through foreign public \
-transport networks. It finds the shortest or direct route from a start to a \
-destination station of the loaded subway map. U-Bahn Navigator is extensible \
-to support each public transport network."
-PRIORITY = "optional"
-SECTION = "opie/applications"
-MAINTAINER = "Dimitri Brukakis"
-LICENSE = "GPL"
-APPNAME = "ubahnnav"
-APPTYPE = "binary"
-APPDESKTOP = "${S}/src/ubahnnav"
-PR = "r2"
-
-SRC_URI = "http://ubahnstation.net/source/ubahnnav-${PV}.tar.gz \
- file://qmake.patch;patch=1"
-S = "${WORKDIR}/ubahnnav-${PV}"
-
-inherit opie
-
-export OE_QMAKE_LINK="${CXX}"
-EXTRA_QMAKEVARS_POST = "LIBS+=-L${S}"
-
-do_configure_prepend() {
- find . -name "Makefile"|xargs rm -f
-}
-
-do_install() {
- oe_libinstall -so libsubwaymap ${D}${palmtopdir}/lib
- install -d ${D}${palmtopdir}/pics ${D}${palmtopdir}/ubahn/maps
- touch ${D}${palmtopdir}/ubahn/maps/.empty
- install -m 0644 src/ubahnnav/images/u-logo.png ${D}${palmtopdir}/pics/ubahnnav.png
-}
diff --git a/packages/ubahnnav/ubahnnav_0.4.0.bb b/packages/ubahnnav/ubahnnav_0.4.1.bb
index 49e46ac8b0..16924681db 100644
--- a/packages/ubahnnav/ubahnnav_0.4.0.bb
+++ b/packages/ubahnnav/ubahnnav_0.4.1.bb
@@ -10,7 +10,7 @@ LICENSE = "GPL"
APPNAME = "ubahnnav"
APPTYPE = "binary"
APPDESKTOP = "${S}/src/ubahnnav"
-PR = "r2"
+PR = "r0"
SRC_URI = "http://ubahnstation.net/source/ubahnnav-${PV}.tar.gz \
file://qmake.patch;patch=1"
@@ -19,7 +19,7 @@ S = "${WORKDIR}/ubahnnav-${PV}"
inherit opie
export OE_QMAKE_LINK="${CXX}"
-EXTRA_QMAKEVARS_POST = "LIBS+=-L${S} LIBS-=-lqtopia"
+EXTRA_QMAKEVARS_POST = "INCLUDEPATH+=${S}/src/libsubwaymap LIBS+=-L${S} LIBS-=-lqtopia"
do_configure_prepend() {
find . -name "Makefile"|xargs rm -f
@@ -27,7 +27,8 @@ do_configure_prepend() {
do_install() {
oe_libinstall -so libsubwaymap ${D}${palmtopdir}/lib
- install -d ${D}${palmtopdir}/pics ${D}${palmtopdir}/ubahn/maps
+ install -d ${D}${palmtopdir}/pics
+ install -d ${D}${palmtopdir}/ubahn/maps
touch ${D}${palmtopdir}/ubahn/maps/.empty
- install -m 0644 src/ubahnnav/images/u-logo.png ${D}${palmtopdir}/pics/ubahnnav.png
+ install -m 0644 src/ubahnnav/images/u-logo.png ${D}${palmtopdir}/pics/ubahnnav.png
}