aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-13 15:45:51 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-13 15:45:51 +0000
commite0ddd1e7880c88f22e3f90aedc99bddc82895099 (patch)
tree112cfc961abb351d54c274bc99e5a50e00f9ed04 /packages
parentdb8bf575bb112403de566c2cd241a105f646c5a2 (diff)
downloadopenembedded-e0ddd1e7880c88f22e3f90aedc99bddc82895099.tar.gz
ohm: fix depends and packaging
* x11 dependants are in ohm-plugin-x11, leaving a small and contained ohm and libohm package
Diffstat (limited to 'packages')
-rw-r--r--packages/hal/ohm_git.bb33
1 files changed, 30 insertions, 3 deletions
diff --git a/packages/hal/ohm_git.bb b/packages/hal/ohm_git.bb
index 4ef1a6dfa9..cd003b4b72 100644
--- a/packages/hal/ohm_git.bb
+++ b/packages/hal/ohm_git.bb
@@ -2,15 +2,42 @@ DESCRIPTION = "Open Hardware Manager"
HOMEPAGE = "http://freedesktop.org/Software/ohm"
LICENSE = "LGPL"
-DEPENDS = "dbus-glib intltool-native hal"
-RDEPENDS += "udev hal-info"
+DEPENDS = "gtk+ dbus-glib intltool-native hal"
+RDEPENDS_${PN} += "udev hal-info"
SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git"
PV = "0.0+git${SRCDATE}"
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
EXTRA_OECONF = "--with-distro=debian"
+
+do_configure_append() {
+ rm config.log
+}
+
+OE_LT_RPATH_ALLOW=":${libdir}/libohm:"
+OE_LT_RPATH_ALLOW[export]="1"
+
+PACKAGES =+ "libohm ohm-plugin-x11"
+
+FILES_${PN}-dev += "${libdir}/ohm/*.la \
+ ${libdir}/ohm/*.a "
+
+FILES_${PN} = "${sysconfdir} \
+ ${bindir}/* \
+ ${sbindir}/* \
+ ${libdir}/ohm/*.so \
+ "
+
+FILES_libohm = "${libdir}/libohm.so.*"
+FILES_ohm-plugin-x11 = "${libdir}/ohm/libohm_x*.so \
+ ${libdir}/ohm/libohm_idle.so \
+ ${sysconfdir}/ohm/plugins.d/x* \
+ ${sysconfdir}/ohm/plugins.d/idle* \
+ "
+
+