aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-09-16 14:54:52 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-16 14:54:52 +0000
commite6e5f0ec0947a67a87854e51deb68efadc7246e8 (patch)
tree2418902abdfe15a1e073a5df815e99f459573f89 /packages
parent63b953a884d78372cfe22908014f12f0892db4e1 (diff)
downloadopenembedded-e6e5f0ec0947a67a87854e51deb68efadc7246e8.tar.gz
gnuz: switched from generating levels during build to pregenerated ones
- generator used Qt/X11 so it was impossible to build it without running X11
Diffstat (limited to 'packages')
-rw-r--r--packages/gnuz/gnuz/.mtn2git_empty0
-rw-r--r--packages/gnuz/gnuz/intro_level.patch14
-rw-r--r--packages/gnuz/gnuz_0.3.bb51
3 files changed, 14 insertions, 51 deletions
diff --git a/packages/gnuz/gnuz/.mtn2git_empty b/packages/gnuz/gnuz/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gnuz/gnuz/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gnuz/gnuz/intro_level.patch b/packages/gnuz/gnuz/intro_level.patch
deleted file mode 100644
index ad1a69dff0..0000000000
--- a/packages/gnuz/gnuz/intro_level.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- ../intro.conf.orig 2003-09-13 18:55:01 +0200
-+++ ../intro.conf 2004-10-12 23:35:18 +0200
-@@ -1,8 +1,9 @@
- LevelName=Welcome Screen
- LevelAuthor=WarCow
--LevelPicFilename=intro_new.png
--LevelMaskFilename=intro_new_mask.png
-+LevelPicFilename=intro.png
-+LevelMaskFilename=intro_mask.png
- LevelDifficulty=0
-+LevelParTime=0
-
- GnuCount=23
- GnuMinSave=0
diff --git a/packages/gnuz/gnuz_0.3.bb b/packages/gnuz/gnuz_0.3.bb
index 23a1832596..3e986cf398 100644
--- a/packages/gnuz/gnuz_0.3.bb
+++ b/packages/gnuz/gnuz_0.3.bb
@@ -5,49 +5,26 @@ MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
LICENSE = "GPL"
AUTHOR = "Lukas Fraser"
HOMEPAGE = "http://gnuz.4cows.net/eraser/gnuz/"
-DEPENDS = "gnuz-levelmaker-native gnuz-package-native"
+PR = "r1"
+
+APPTYPE = "binary"
+APPNAME = "gnuz"
+APPDESKTOP = "${S}/data/"
SRC_URI = "http://gnuz.4cows.net/eraser/gnuz/gnuz_0.3.tar.gz \
- http://gnuz.4cows.net/eraser/gnuz/gnuz_0.3_levels.tar.gz \
- file://intro_level.patch;patch=1;pnum=0"
+ http://www.hrw.one.pl/_pliki/oe/files/gnuz-levels-0.3.tar.bz2"
S = "${WORKDIR}/gnuz"
-export OE_QMAKE_LINK="${CXX}"
-EXTRA_QMAKEVARS_POST += "LIBS+=-lqpe"
-
-inherit palmtop
-
-do_compile_append() {
-
- cd ${WORKDIR}
-
- for level in *.conf
- do
- if [ $level != 'intro.conf' ] ;then
- ${STAGING_BINDIR}/gnuz_levelmaker `basename $level .conf`.lvl $level
- fi
- done
- ${STAGING_BINDIR}/gnuz_levelmaker intro intro.conf
- cd ${S}/data/
- ${STAGING_BINDIR}/gnuz_package guiimages.dat gui
- ${STAGING_BINDIR}/gnuz_package gnuimages.dat gnu
-
-
-}
-
-do_install() {
+inherit opie
- install -d ${D}${palmtopdir}/apps/Games \
- ${D}${palmtopdir}/pics \
- ${D}${palmtopdir}/bin \
- ${D}${palmtopdir}/share/gnuz/levels
+do_install_append() {
- install -m 0755 gnuz ${D}${palmtopdir}/bin/
- install -m 0644 data/gnuz.desktop ${D}${palmtopdir}/apps/Games/
- install -m 0644 data/gnuz.png ${D}${palmtopdir}/pics/
- install -m 0644 ${WORKDIR}/*.lvl ${D}${palmtopdir}/share/gnuz/levels/
- install -m 0644 ${WORKDIR}/intro ${D}${palmtopdir}/share/gnuz/levels/
- install -m 0644 ${S}/data/*images.dat ${D}${palmtopdir}/share/gnuz/
+ install -d ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/share/gnuz/levels
+ install -m 0644 data/gnuz.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/gnuz-levels/share/gnuz/levels/* ${D}${palmtopdir}/share/gnuz/levels/
+ install -m 0644 ${WORKDIR}/gnuz-levels/share/gnuz/*images.dat ${D}${palmtopdir}/share/gnuz/
}